Red5 Openfire plug-in is there, then it's not there

Hey there,

We have recently installed Openfire 3.5.1 and have successfully implemented it. I tried to follow the installation instructions to a tee, but I ran upon a mis-install or bad install of Red5. Sometimes, the plug-in shows up as being there, sometimes not. I have tried to uninstall the plug-in, too, and it says it’s uninstalled, but it reappears after a page refresh sometimes.

Also, am I correct in reading that the Openfire plug-in and the Spark plug-in are two different files? One being a .war (what’s .war anyway?) and the Spark plug-in being a .jar?

Edit:// I should add that I’m running OpenFire on a Windows server…

I would also like to confirm that the readme line: “Copy the red5.war file to the Openfire_HOME/plugins directory.”

just means Openfire/plugins… there is no Openfire_HOME/plugins directory.

I attempted a fresh install of Red5.war, and the server spit a bunch of red back in my face:

Jun 18, 2008 12:53:44 PM org.jivesoftware.openfire.plugin.red5.Red5Plugin initializePlugin
INFO: Initializing red5 Plugin
Jun 18, 2008 12:53:44 PM org.jivesoftware.openfire.plugin.red5.Red5Plugin startPlugin
INFO: Registering red5 as a component
Jun 18, 2008 12:53:44 PM org.jivesoftware.openfire.plugin.red5.PacketHandler startPacketHandler
INFO: Starting PacketHandler
Jun 18, 2008 12:53:44 PM org.jivesoftware.openfire.plugin.red5.Red5Plugin initialize
INFO: Creating web service red5
Jun 18, 2008 12:53:44 PM org.jivesoftware.openfire.plugin.red5.Red5Plugin initialize
SEVERE: Illegal context spec:null
java.lang.IllegalArgumentException: Illegal context spec:null
at org.mortbay.jetty.handler.ContextHandlerCollection.mapContexts(ContextHandlerCo
at org.mortbay.jetty.handler.ContextHandlerCollection.setHandlers(ContextHandlerCo
at org.mortbay.jetty.handler.HandlerCollection.addHandler( 97)
at org.mortbay.jetty.servlet.Context.<init>(
at org.mortbay.jetty.servlet.Context.<init>(
at org.mortbay.jetty.webapp.WebAppContext.<init>(
at org.jivesoftware.openfire.plugin.red5.Red5Plugin.initialize( )
at org.jivesoftware.openfire.component.InternalComponentManager.addComponent(Inter
at org.jivesoftware.openfire.plugin.red5.Red5Plugin.startPlugin( 5)
at org.jivesoftware.openfire.plugin.red5.Red5Plugin.initializePlugin(Red5Plugin.ja va:80)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin( :448)
at org.jivesoftware.openfire.container.PluginManager.access$300( :47)
at org.jivesoftware.openfire.container.PluginManager$
at java.util.concurrent.Executors$ Source)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ n Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)

I changed the port to 8080 and I made it into the /red5/red5.html, but the Spark plugin that’s supposed to be there isn’t there.

Instead, when I click :

Spark Plugin

You can download the Spark Red5 client application plugin from here

I get the Jetty error:



+[Powered by


Change the end of the link from “/red5/red5-plugin.jar” to “/red5/spark/red5-plugin.jar” in the red5.html file.

Thanks. I’ve had Red5 stable for some weeks now. My big issue lately is getting it to work on a Mac. See this thread.

I have added soms sort of support for the spark plugin for Macs in version 0.0.22, but I have no idea if it will work. Let me know what happens as soon as you can test it.