powered by Jive Software

Red5 plugin not working

running Openfire 3.7beta on Windows Server 2003 64bit with a very basic install. So far, all the basic features seem to work fine with 2 users setup and two clients running Spark 2.6beta on Windows 7 64bit.

i’ve been trying to get the red5 plugin to work

i’ve loaded red5.war (download off this page from Projects -> Openfire -> Plugins -> Beta Plugins) into the Openfire webadmin using the plugins page, but, even though the page tells me it was uploaded successfully, it never appears in the list of installed plugins.

i also tried manually copying the red5.war file to the /plugins directory on the server

one of those two steps resulted in the automatic creation of the /plugins/red5 directory, so that means something worked

however, the webadmin still does not show any mention of the red5 plugin, nor does it show any red5 properties on any page

not surprisingly, trying to navigate to http://server_ip:http_bind_port/red5 does not work

and neither do my clients work with red5 (though i did copy the red5-plugin.jar from the server and it shows up as a menu on the clients successfully

any help?

Edit: The answer to this question ended up being that the current red5.war plugin does not currently work in Openfire 3.7 nor in Spark 2.6. It WILL work eventually but under the new project called “redfire”