powered by Jive Software

Red5Plugin 0.1.11 - Possible SIP Bug

I am testing for over 2 days now and this problem keeps ocurring:

SIP Server: Asterisk 1.4.18

Openfire 3.6.2 + Red5Plugin 0.1.11

Using Red5phone

All users are registering SIP phones and can call everyone, although after a few seconds JAVA (SIP Plugin) just does not answer the INVITE.

* Test - Case 1:

A calls B and B pickup/answer (call ok, sound ok… everthing good). Then A hangup the call. When B try to call A it (B) send INVITE to SIP Server but Java does not receive any “Incomming” call from Asterisk. It seens to not get the call sent by Asterisk.

Details:

  • A and B are users from same Server (assterisk)

  • A and B are in local network

  • Theres no firewall between the users or even between the user and server

* Test - Case 2:

A calls B and B pickup/answer (call ok, sound ok, everthing good). A hangup the call, unregister and register again. B calls A and now it works.

It really seens to be an issue on Java Plugin, I changed expire times and renew times for SIP Register and this problem is reduced but not solved at all.

I tried to put “unregister()” method on “hangup” process but it does not seens to work as expected.

Is there anything on new release related this situation?