powered by Jive Software

Red5plugin don't work

I had installed Openfire 3.6.4 on debian, I try to install red5 plugin from http://red5.4ng.net/red5-0.1.11.zip and from svn trunk, it installed ok, but when I try to make a call it do nothing, http://domain.com:7070/red5 write that all installed ok, when I press “login” it write “connection succes”, but realy it don’t register on asterisk and don’t try to make a call, from sparkweb situation is same(IM works fine). But from spark calls work normally. Where I can see red5 logs, I had java:

java version “1.6.0_12”
Java™ SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot™ Client VM (build 11.2-b01, mixed mode, sharing)

red5 URL is rtmp:/sip

Maybe I had wrong configuration of Red5 plugins or some problems with java?

P.S. Sorry, for my English…


same f++king problem here.

openfire-server runs on windows OR linux. but red5 won’t work. i tried the first time the rd5-plugin from the client (copy to …/openfire/plugins) and after that your zip-file-link from 4ng.net, cause the (very, very bad) documentation at http://www.igniterealtime.org/community/docs/DOC-1520 says i should take http://red5.4ng.net/red5.war but i get an HTTP 404 instead.

Anyway … I copied first the jar-, second the war-File to plugins, but i can’t see it in the plugins-list on my webinterface…

P.S. sorry for my english, too

Does the very very bad documentation tell you to stop and restart Opennfire server?

I do it for many times, nothing help…I try to reinstal plugin, start and stop it and nothing. But my sip plugin work correctly, don’t work only red5phone plugin when I try to call and sparkweb, but web page of red5 plugin load normally and write that all installed with no problems, in Openfire Red5 plugin also installed, I see it and can change settings(I post png images).

Where I can see logs of red5plugin?

@dele:

yes and no. the docu says “restart the server after red5-plugin-installing”. ok.

but the docu says NOT “unpack openfire, run …bin/openfire start, config via webinterface and THEN RESTART OPENFIRE AGAIN”. after the webconfig there is a button for direct admin-console-login, but the access is denied. the interface don’t accept my admin-password. after restart openfire you can login, cause the password will be known by the server. spooky. (using embedded database)

now my openfire 3.6.4 works with red5. the quality isn’t very good and my biggest problem is: i can’t resize the webcam-window. but anyway, it’s video over xmpp…

the following page helps me to run red5 quickly: http://www.igniterealtime.org/projects/openfire/plugins-beta/red5/readme.html

but IMHO this isn’t the first document where i’m looking for help. so i need a long time to find it. and there are a lot of useful hints.

btw, you find red5.war here: http://www.igniterealtime.org/projects/openfire/plugins-beta.jsp

and btw too: video-calls will only work via sparkweb for me. with spark i have no chance to run it and i don’t know why (yes, i installed the red5-client-plugin, but there is missing an option in my spark-menu for making video-calls =)

Image2.jpg

Deafult video quality settings are set low to conserve bandwidth. Look at the Flex Camera object documentation to see how to change these values to improve quality.