powered by Jive Software

Redfire not working

Hello everyone.

I installed redfire 0.0.5 on my Openfire 3.7.0

I installed redfire 0.0.9 on spark 2.6.3

Now when I try to start a video conference, both person get a grey screen. After a little while at the bottom of that screen it says: Enter… connected

But nothing else. No voice, no video.

I attached the logs of spark.

Any idea on what the problem is?

Thanks
log.txt.zip (640 Bytes)

I also forgot to mention what we are on the same subnet.

We also have the same version of spark and the plugins.

We both run Flash 10.3.181.23

Also, I saw a few screenshots showing buttons to accept or decline audio video conference. What me and my co-worker see, is simply a link. Any idea how to change that?

Could you please post the warn.log file as well

I found why.

The port 1935 on my openfire server was blocked by SuSE Firewall.

So now screensharing and audio/video work very well.

1 more thing:

It happens very often that I am unable to close the screensharing or the audio/video window. Only way I can do it is by killing spark all together. Any idea why?

I am using windows XP SP3 on a dual core machine.

First off, I am very new to Openfire/Spark and Redfire. My interest was triggered by a suggestion by a fellow ham radio enthusiast who suggested using Openfire as the basis for HSMM (High Speed Multimedia) operating. Basically this is communications via WiFi devices, generally using the amateur radio allocation of the 2.4 GHz band. Communications can be ad hoc point to point or via a mesh network. Netmeeting had been a commonly used application but that is no longer supported by MS and it only works with Windows machines.

I have installed Openfire on a home server and did all of the necessary port forwarding for friends to use it via the internet as it is normally intended. It works great with text chat, screen capture and file transfers. I also installed it on a couple of laptops w/o internet as point to point ad hoc and likewise it works well. I had never paid much attention to XMPP before but I’m beginning to appreciate it for a lot of reasons.

Where I am stuck - and others seem to be - is getting Redfire to work. I am testing using 2 Win XP machines. I am using the current versions of Spark and Openfire. I have upgraded my Flash to the latest. I placed the .war file in the Openfire plug in folder and it seems to have done its thing but it does not show in the plug in screen for Openfire.

On the Spark side I placed the .jar file in the plug in folder and the audio/video and screen share icons show in the Spark chat window. When I try a screen share I get the request to accept/reject the share but then when I accept I see a new screen with HTTP Error 404: Problem accessing /redfire/screen/screenviewer.html. Reason: Not Found

Is there an additional plug in or other application that I should be installing within Spark or elsewhere?

Thanks much.

Steve

I hope you restarted your Openfire server after installing Redfire. If that does not hhelp, the only way we can help is if we see the Openfire log files. You can zip the whole folder and send to me as a private message if you like.

Restarted several times

The only other thing I can think of at the moment was that I am connecting between the two PCs using the IP address of the server, not the xxxxx.dyndns.org URL. I think I saw a note somewhere that there is a difference.

If that doesn’t work I’ll send you the log files.

Thanks for the quick response.

Steve

I’ve got the log file zipped. How do I send it as a pm to you?

Steve

You can post to my email account or use the ignite realtime private message

Just to do a summary, after you found from my log files that I grabbed the wrong redfire war file, I deleted the old one from Openfire and along with the redfire folder, placed the new/correct file in the plugin folder and then restarted Openfire. The redfire plug in was then listed in the console and it all worked.

This was on the networked PCs. Next I’ll try the same with the two PCs on the ad hoc network and then try video.

Thanks much for your help Dele.

Steve

I open also port 1935 but still not working from outside

localy working fine

please help

open also port 1935 but still not working from outside

localy working fine

please help