powered by Jive Software

RedFire Phono - Help Needed, Will Pay

Looking for someone with experience in RedFire Phono. I am trying to get the system up and running for a voice chat on my website but have received nothing but headache trying to get it to work. (And I have very little system admin knowledge)

I have been able to send out calls to the standard sip@mouselike.org number and connect, but am unable to connect to two IDs on the same server. (I.E. Open up two browsers and copy the ID off of one page into the other and connect a call - It will just ring on one browser and not receive the call on the other). It should also be noted calling from one browser to another browser this is something that I CAN do on the Phono website see here (http://s.phono.com/releases/0.5/samples/kitchen-sink/www/index.html).

I’d really like to get this set up so I can integrate chatting into my websites chatrooms.

If you think you can help let me know the total est $ or an hourly rate.

Someone please help!!!

Image2.jpg

Did you put xmpp: in front of the sessionId (JID)?

I have uploaded the latest version which now supports WebRTC audio on Chrome 23 which is more reliable than Flash (RTMP/RTMFP) for calls between web users, but does not yet work with SIP phones.

For SIP calls, you can either use Flash or the new “phoneback” audio type. It is a SIP phone callback which can make a call to the destination with your desktop SIP phone. It is also known as back to back calling I have tested only on my Aastra IP desk phone.

The Call doesn’t go out at all when I use the xmpp:jid@domain.ext & I don’t need SIP, so WebRTC would be wonderful. Unfortunately when I make an outgoing call (WebRTC or Flash), all I get is:

Call4 Outgoing call to: xmpp:fb3e88fe@wishmedia.im

It doesn’t ring or anything. Through Regular Flash I am able to call the SIP (but as you previously said,not through the WebRTC).

It doesnt seem to want to make a connection…? Please help!!! I’m sure it’s something easy to someone who knows whats going on with it - I will pay!!!

P.S. I am using Chrome, but I tried this on multiple platforms all with the same outcome.

Look at my example :slight_smile:

You should have used the full JID

xmpp:fb3e88fe@wishmedia.im/fb3e88fe

and not

xmpp:fb3e88fe@wishmedia.im

Go and read up on basic XMPP. It will save you many furstrating hours (and money). An XMPP user can have many sessions each with different resource Ids

Ony chat messages are sent with bare JIDs and the server delivers to each session. Requests (IQ) are sent to specific sessions and you must provide the full JID.

Thanks Dele!

It works with the flash, it makes sense that you would need the resource. Is there any reason why you didnt put the full JID for the Session ID? It might eliminate some confuison for other newbies.

I tried this with the WebRTC option but that still doesn’t seem to make the call.

This is what I get:

Call2 Outgoing call to: xmpp:1ab82cc7@wishmedia.im/1ab82cc7

But it doesnt connect.

Do I need to use additional plugins or install something else on my server to allow WebRTC to work?

I am using Google Chrome Ver. 23.0.1271.101

Also, Doing a quick read of the WebRTC web page (webrtc.org), it looks like it is only compatable with Google, Mozilla and Opera. I also noticed there is a webrtc4all extension (http://code.google.com/p/webrtc4all/) which provides compatability for Safari and IE as well.

Do you recommend sticking with Flash for compatability across more browsers?

Thanks again for all your help!

Sorry about the poor documentation. My bad

WebRTC is only available in Chrome and Firefox and both are incompatible with each other right now. It will be a while before it is available on all browsers working properly with each other using the agreed codecs.

If you want something that works on all browsers right now, then it is Flash, but don’t forget WebRTC was created to solve all the problems we had with Flash

Just tested redfire-phono on my server with WebRTC and it works fine. I assume you noticed the permission bar in Chrome and allowed it access to your microphone as well as setting both users to audio type webrtc.

Awesome,

I guess i’ll stick with flash for now, what problems were you having with Flash?

Also, I was looking through your Redfire examples: 4 Person Audio Conference, and I noticed it uses specifically Flash. I was sifting through some Phono examples trying to figure out how to do a conference and found out you can’t do it with Phono due to the “voice bridge”.

On our last message you mentioned something about openlink, is there any examples on how to go about setting up a conference with openlink? Or any examples at all on doing a voice conference chat system with Redfire?

Again, thanks for all your help