Regarding Unicode

In the Database Installation Guide, there is this note about MySQL and Unicode:

MySQL does not have proper Unicode support, which makes supporting data in

non-Western languages difficult. However, the MySQL JDBC driver has a

workaround which can be enabled by adding

true to the section

of your wildfire.xml file. When using this setting, you should also set the

Jive character encoding to utf-8 in the admin tool.

I can’'t find the character encoding setting in the admin tool. Is this the same as changing the locale in wildfire.xml?


Hi Andrew,

I suppose the setting doesn’'t relates directly to UTF-8. A couple of the things that locale does is the way the date and monetary values are displayed.

Jabber/XMPP spec is already UTF-8. Thefore, Wildfire should already support UTF-8 and there shouldn’‘t be any setting to disable this. MySQL default is not UTF-8, and so you’'ll need to inform MySQL to do so. The perhaps vaguely said UTF-8 setting in the admin tool refers to the setting in the browser. Also, the option to choose language in the admin tool refers to translation only.

You know, I thought XMPP was already Unicode, but I have a user reporting problems with Unicode and Asian character sets. I’'ve asked for more detail (screenshots) so that I can get a handle on the nature of the issue.

He’'s using Exodus, btw.


I wonder if this is client specific issue. Perhaps you could ask them if they face the same problem when they use clients other than Exodus. In the mean time, you’'d probably want to enable the debug packets in the admin console to see if Wildfire handles those characters properly.