powered by Jive Software

Registration Plugin on 3.4.0

I installed the Registration plugin on openfire 3.4.0 and all the options show up on the admin console but when someone registers it doesn’t do any of the options I set.

Hey Tim,

I just tested Registration 1.4.0 plugin with Openfire 3.4.1 and it worked fine. However, note that if you enter a bare JID (e.g. john@server.com) instead of just a username in IM Contacts to alert then the plugin will appear to do nothing since it is having some errors that you can see in your logs. I will fix this problem and upload a new version of the plugin. For now, make sure that you are just entering a username and not a JID in the users to alert. If that is not your case then check your error log and post the errors that you see. I will wait for your reply before uploading the new version.

Thanks,

– Gato

When I tested it I couldn’t get it to put someone into a group or send a welcome message. I used the me@servername.com in the notify option and I didn’t get anything. None of the features worked for me on 3.4.0

actually if I take out the JIDs that are something@servername.com it works.

Thanks,

Tim

Yes, that is exactly what I was referring to. Is email notification working for you? Are you using it? I haven’t tested it but I guess that a valid email address is needed there and not just a username.

Will upload the new version in a moment.

Thanks,

– Gato

I didn’t use the email notification but the welcome message, IM notify, and the auto group works as long as you have the short JID in the notify options.

Done. Registration 1.4.1 has been released.

Thanks,

– Gato