powered by Jive Software

Registration Required Error (407) when im already registerd?

Please, I really really need help. Ive been stumped on this for 3 days now. Problem Discription is below:

I am trying to register with an Aim transport. The steps I have taken are as follows.

  1. Created an account using the AccountManager class. Seems successfl as i recieve: <iq id=’‘2pXk7-1’’ type=’‘result’’/>

  2. Created a registration packet, added the necessary aim username and password and sent it to aim.transactim.net. Seems successful as I recieved: <iq id=’‘reg’’ type=’‘result’’/>

  3. logged in using my newly created username and password. Seems successful as I recieved again a result packet and a welcome message.

  4. Then I try to create a roster and add AIM Gateway to the transport group:

Roster roster = conn.getRoster();

String[] cat={“Transports”};

roster.createEntry(“aim.transactim.net”,“Aim Transport”,cat);

This is where the problem lies. Looking at what I see in the debugger, things look good until I see an error packet:

<item jid=’‘aim.transactim.net’’ name=’‘Aim Transport’’ subscription=’‘none’’>Transports

<iq id=’‘eDy9T-4’’ type=’‘result’’ from=’‘xxx@transactim.net/Smack’’ to=’‘xxx@transactim.net/Smack’’/>

<iq type=’‘set’’><query xmlns=’‘jabber:iq:roster’’><item jid=’‘aim.transactim.net’’ name=’‘Aim Transport’’ subscription=’‘none’’ ask=’‘subscribe’’>Transports

<presence id=’‘eDy9T-6’’ to=’‘xxx@transactim.net’’ type=’‘error’’ from=’‘aim.transactim.net’’><error code=’‘407’’>

Registration Required

Why am I recieveing this 407 error when I have already registered. Additionaly, (Im not sure if this is related to the above problem), Ive tried to use Jbother to verify if my transport is working, and it lists “AIM Gateway” as offline. I also dont see the “/registerd” appended to the gateway, which is what I think it should say(not sure). I also cant send/recieve messages to a user. When trying to send from aim to Jbother, the aim window kindly promps me that the aim username( the one im registered under the gateway) is offline. Much thanks in advance.!!

frustrated spawn

Hey spawn,

Have you tried using another client? Try using Exodus and see if you get the same error. I guess that this is a problem with the gateway and not with the client. If it works with exodus then I’'d recommend comparing the packets sent and received from the server. Press F12 to open the Exodus debugger. But if the problem is within the gateway then you should contact the gateway developers and report the problem in their forums.

Regards,

– Gato