powered by Jive Software

Repeated crashes on MacOSX

I have an issue with the spark client on Mac OSX 10.7.5 WHen I run the Spark IM client I am disconnected every minute or so. It will reconnect, and then disconnect again. I have done Uninstalls and re-installs. The message is “Your connection was closed with an Error”

The strange thing is that I can shutdown spark on the Mac side, open it under windows parallels and the same thing will occur with the windows version.

THis is the error I get on the WIndows side:

Nov 27, 2012 10:24:41 AM org.jivesoftware.spark.util.log.Log error
SEVERE:
No response from the server.:
at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:209)
at org.jivesoftware.sparkimpl.plugin.scratchpad.Tasks.getTaskList(Tasks.java:205)
at org.jivesoftware.sparkimpl.plugin.scratchpad.TaskNotification$2.run(TaskNotific ation.java:73)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

On the Mac Side it appears to be a similar error:

Nov 27, 2012 10:49:26 AM org.jivesoftware.spark.util.log.Log error
SEVERE:
No response from the server.:
at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:209)
at org.jivesoftware.sparkimpl.plugin.scratchpad.Tasks.getTaskList(Tasks.java:205)
at org.jivesoftware.sparkimpl.plugin.scratchpad.TaskNotification$2.run(TaskNotific ation.java:73)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:702)
at java.awt.EventQueue.access$400(EventQueue.java:82)
at java.awt.EventQueue$2.run(EventQueue.java:663)
at java.awt.EventQueue$2.run(EventQueue.java:661)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlConte xt.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:672)
at org.jivesoftware.sparkimpl.plugin.idle.UserIdlePlugin$1.dispatchEvent(UserIdleP lugin.java:182)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:29 6)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:20 1)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I have on multiple occasions un-installed and re-installed the client on both OSs. I am sure that they are not running simultaneously. I appear to be the only one in the office with this issue, but am also the only Mac user. I feel like it may be some kindof network issue, but I also run multiple CIrrix based apps from here and they do not drop as would be suggested if it was a general connectivity issue.

The only other thing, and I have not had as much time to confirm this as I’d like is that if I connect from home over VPN I do not seem to have the same problem.

I did confirm last night that when I am connected through VPN I don’t have any issues with being disconnected.