powered by Jive Software

Reports do Fastpath não funciona

Boa Tarde!

Comecei a utilizar o fastpath em meu openfire esta semana e aparentemente está 100% funcional. Só tenho um problema, que gostaria de ajuda de vocês para resolver: Os reports, ou seja, o histórico das conversas não está funcionando. Exemplo; se coloco o periodo do dia 21/01(ontem) até 21/01(ontem) ele nao me retorna nenhuma conversa, apesar de haver conversas pois fiz vairas de teste. Se coloco 22/01 a 22/01 mesma coisa, apesar de ter conversas hoje ele nao mostra, mas se coloco 21/01(ontem) até 22/01(hoje) ele tras as conversas de ontem no resultado.

Outra situação, eu poderia utilizar como visialisador do historico de converas o monitoring que por sinal e muito bom e ja vi na internet alguns exemplos de que ele funciona para visualizar as conversas do fastpath MAS no meu caso aqui, so aparece neste histórico o registro dos usuarios entrando no chat e saindo mas sem as mensagens da conversa.

Trocando em miudos, não tenho histórico das conversas do chat em lugar nenhum, alguem sabe como resolver isto ? Mexer no codigo ? onde ? como ? aguardo ajuda. obrigado !

complementanto… no monitoring eu consigo visualizar perfeitamente as conversas dos usuarios registrados no openfire, sem problema algum. Meu problema está so nas conversas do chat(fastpath).

PS.: Utilizo Openfire 3.6.4, plugins: Broadcast, Client Control, Email Listener, Fastpath Service, Fastpath Webchat e Monitoring Service e Banco: PostreSQL.

Olá,

crie uma fila além da fila padrão e crie também novos usuários, adicione os usuários a nova fila. Faça conversas de modo a gerar conteúdo para o relatório, depois tire o relatório novamente filtrando pela fila que você criou.

jp.

OK. So que como especifico o relatorio por fila ? so tem a opção de selecionar o workgroup e nao a fila do mesmo.

hmm… p/ mim aparece mas não sei te dizer se desenvolvemos esse campo (não sou só eu que trabalho no Openfire aqui) ou é padrão do Openfire.

Pelo que me lembro não criamos.

aqui nao tem.

a propósito, fiz o teste que vc indicou e ai vai os resultados:

Relatório via Reports do Fastpath:

No Chats have occured in this workgroup.

Relatório via Monitoring:

[13:25]
Vinicius Lima (Vinicius Lima) has joined the room
[13:25]
atendimento (atendimento) has joined the room
[13:25]
João (anonymous) has joined the room
[13:26]
João (anonymous) has left the room

e nada mais.

veja nas imagens em anexo.


Amigão faz o seguinte, desabilita o gravação de chatlog, Salva, depois habilita novamente e Salva.

Infelismente não resolveu =/

Que chato , comigo aconteceu a mesma coisa na fase de testes ele gravaa a conversa do spark normalmente mas não do FasthPath. disable e enable funcionou. vou dar uma pesquisada para ver se consigo te ajudar mais.

Agradeço !

Qdo vc fala em desabilitar vc refere-se a esta tela aki né: anexo

acabei de olhar no banco a tabela ofmessagearchive onde ficam os registrs de mensagens e não aparece NENHUMA linha referente as mensagens enviadas via webchat fastpath

acho q por isso nao aparece no log do monitoring mas e onde estaria meu problema ?

olá pessoal.

eu sei que o que vou falar é básico, mas…

não sei no fastpath, mas em outras opções do openfire, eu só consegui o resultado que queria reiniciando ele.

você já tentou parar o openfire e reiniciar ele novamente.

té+

Hamilton

“… Não esqueça de fazer parte da nossa comunidade Brasil!”

Não resolveu.

Acho que vou ter que reinstalar todo Openfire e deixa-lo zeradinho incluindo a recriação do banco p/ ver isso funcionando…

chega da uma tristeza…