powered by Jive Software


hi Flow and all, i’m using openfire 3.9.1 and the stream log like:

SENT (0): <stream:stream to=“” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

RCV (0): <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client” from=“” id=“84d17d5” xml:lang=“en” version=“1.0”>

RCV (0): stream:featuresDIGEST-MD5PLAINCRAM-MD5zlib</stream:features>

and don’t have a bind, so in PacketReader’s parseFeatures(parser) method,

else if (parser.getName().equals(“bind”)) {

// The server requires the client to bind a resource to the stream



is never called, and in XMPPConnection

if (!bindingRequired) {

// Server never offered resource binding, which is REQURIED in XMPP client and server

// implementations as per RFC6120 7.2

throw new ResourceBindingNotOfferedException();


how can i fix this? thanks a lot

The server is required to send a new feature stanzas including “bind” after successfull SASL authentication as per RFC 6120 7.4. I don’t think that this is the feature stanza whe are seeing here because it still contains the SASL mechanisms.

I have the same problem in 4.0.0.rc2. When the SecurityMode is enabled a get a NoResponseException on login. After deactivating the SecurityMode I now get a ResourceBindingNotOfferedException. I only get it in rc2, in rc1 with a deactivated SecurityMode everything works.

I’m locking this thread in favor of http://community.igniterealtime.org/thread/52438

Please continue all discussion related to ResourceBindingNotOffered in 4.0.0-rc2-SNAPSHOT there. Thank you.