powered by Jive Software

REST API plugin 1.3.8 rest-api.jsp not found?


#1

I just updated the REST API plugin from 1.3.7 to 1.3.8 in Openfire 4.2.3. When I clicked the REST API link in Server Settings tab, I got error 404 about plugins/restapi/rest-api.jsp not found. I checked the web.xml mapping and it seemed OK. I could not find any logs for this error. Not sure if this plugin requires Openfire 4.3.x (the new JspSourceImport class requirement as in DB Access plugin.) Does anyone have a similar issue?


#2

Yes, looks similar. Have filed as https://github.com/igniterealtime/openfire-restAPI-plugin/issues/21
Btw, you can file an issue for plugins yourself :wink: Only Jira is read only.