RHEL/CentOS/Debian/W2k3 can connect to LDAP but cannot validate password

Hello Pals, I hope somebody can help me with this issue. As my subject indicates, I can connect to LDAP (OpenLDAP) but I cannot validate the password of any LDAP user. I´m going to be more specific. I have installed Openfire in RHEL, CentOS, Debian and W2k3 always in VMs over Citrix XenServer, and I always get the same error. I can configure the setup without troubles, using a MySQL database. Then I proceed to configure LDAP and I get “Status:Succes” in the connection settings test (Use connection pool: YES / all other settings: NO). I can go through the three steps of the “Profile Settings” setup without troubles, although, I have to admit that in the second step “User Mappings” all fields are blank.

My problem begins when I have to add an Administrator account. For example, in my LDAP , I have the user TEST01. I can add TEST01 as an Administrator without trouble, but when I test the password using the test button of the setup, It returns me “Status: Authentication Failed. Password is incorrect” and I´m positevely sure that the password is the correct. Obviously I did the same test with other LDAP users and I always get the same error, I can add them without trouble but I can`t validate the password.

Let´s suppose I skip the password test and finish the setup, then I can`t login to the administration console. Again the same error, invalid password.

An extra data: after I have finished the setup, when I check the openfire.xml file, it does not contain any LDAP information.

OS: RHEL 6 / CentOS 5.4 / W2k3 SP2



MySQL: 5.5.16

LDAP version: OpenLDAP v over Slackware Linux 9.1

Does anyone has any clue of what could be going on here?

Any information will be appreciated.

Thank you!

I found the solution in a old post.


Login to admin console and proceed with the setup normally. Add an LDAP user as an Administrator.


  • Edit openfire.xml

  • Add:



  • Start OPENFIRE

Login to the admin console.

It should Work.