powered by Jive Software

Running Jitsi Videobridge Openfire Plugin with NATed IP – possible or not?

Is it possible to have Openfire server with NATed public IP address and get Videobridge working out (and in) of the network or do I have make sure the server has public IP address directly assigned to it?

If this is possible could somebody advise me how to do this on Openfire 3.9.2 and Videobridge 1.3? I’ve NATed the public IP and opened required ports (UDP 50000-60000) but can’t get it working (not video on offmeet) but when I’m connected to the network over VPN this is working fine.

Thank you.

For this who have similar problem:

  1. Add the following to the file ~/.sip-communicator/sip-communicator.properties (in the home of user running the videobridge): I userd “find” command to locate the file

  2. In mine case it was empty so I had to add following lines:
    **org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
    org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=192.168.1.1 (of course this will be your local IP)
    org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=5.5.5.5 (this is your public IP)
    **

    1. Save file and restart the server.

    2. Open UDP ports 5000-6000 on top of 50000-60000 required on both external firewall and local firewall

All above fixed mine problem.

Thanks for ther tip

I am using Ubuntu and I see the user openfire has control over the plugin. the home directory for openfire user is /var/lib/openfire do I need to put the directory and file in there? or do i just need to edit the sip-communicator.properties located in the plugin directory?

thanks, Jason

Hi Jason,

I’ve just got access to the file using:

sudo -i

and then cd to /var/lib/openfire/plugins/jitsivideobridge

edited the file using vi

Well I’m encountering the same issue even havein a server on a public IP.

I’ve Jinglenodes plugin and websocket installed. The first plugin is work fine afaik (tested with jitsi clients placed on different networks, the active channel count is incremented), don’t know if websocket works or not.

The real thing is that even being in public ip configuration I can perform meeting only with these 2 config:

External client (not behind nat) / External Client (not behind nat)

Inside LAN client / Inside LAN client

I tried to use the settings suggested for the situation of the server without public IP with no success. Don’t know what is not working.

Regards

This is now gone into version 1.3.1

I have the same problem. In you settings, did you use ice server? And why need to open udp port 5000-6000,for NAT traverse?

edit the sip-communicator.properties located in the plugin directory

hi!

I find 2 files sip-communicator.properties, one in openfire’s user and one in jitsivideobridge directory, which of them must I edit or both