powered by Jive Software

Running Jive Messenger as Windows Service

I’‘ve read as many archived postings around this topic as I could find; perhaps one of them is on this topic, but, I can’‘t find it. So, sorry if I am wasting the forum’'s time with previous material.

I have recently installed your fine product. My environment includes the latest Sun JDK, but an older, not so common version of Windows which might be the cause of the way the problem appears – Windows 2K, Advanced Server, most current service packs.

When I run your messenger-service utility, there is a repeatable, perceptible delay – I can, in fact, watch it come and go through Task Manager, but otherwise, there is no indication of what it is doing, nor any output in any logging location I can find. No matter what command-line argument is chosen, the result is a NOP – no service creation, deletion, invocation, or stop.

Now, I don’‘t know how your service registration is supposed to be accomplished – what entries it tries to create, but on this machine there has always been a registered service called ‘‘messenger’’. Sorry, I no longer have any machines around running other versions of W2K, and no upgrades to any XP variants, so I can’'t do the natural trouble-shooting any other way than to ask for your help. Is there a conflict over the name of the service you are trying to create and a service that already exists? I really would like to put Jive into production and manage it as a well-behaved W2K service.

Thank you.

tcorbet,

Does installing the service fail or starting the service? The default service name is Jive Messenger, so I don’'t imagine that would be a conflict. Something else to verify – try running messengerd.exe and see if the server is able to start correctly.

-Matt

  1. Starting the server from the shortcut that gets installed or from the command line as ‘‘messenger’’ works just fine.

  2. Running ‘‘messengerd’’ from the command line seems to display the same stdout messages – which host/which port – as would otherwise appear in the window.

  3. All that fails is ‘‘messenger-service’’. As stated in the original posting, running that

executable with any of the documented arguments seems to do exactly the same thing. The code remains active for about 3-5 seconds, but produces no output that I can see, and no entries in your /log directory.

If I run my old cygwin strings utility against the .exe file I can see tons of intended error messages are in the code . I’'d expect to see one or more of those messages actually appear somewhere…

For Windows 2000…

http://www.windowstimag.com/atrasados/2000/43_jun00/articulos/resource.htm (in spanish)

http://www.iopus.com/guides/srvany.htm (in english)

On XP Home, messenger 2.2.0 Beta 1 will start as service, but no one but the local user can logon. If I start the gui instead, everything works fine. What do I need to do get service to work properly?

Never mind - forgot to allow thru firewall - duh!