powered by Jive Software

Running Spark on a Terminal Server

Hi,

I’ve just setup OpenFire and Spark and it seems great, but I would like to run it in a Microsoft Terminal Server environment for a selected number of users. Has anyone run it under a Windows 2003 Server Terminal Server environment and if so how did you set the default installation to not “Launch at Startup” as the default behaviour?

Thanks in advance - Alan

Did you ever get an answer to this question?

Thanks

TR

I’m running it in a Win 2k3 terminal server without any issues.

This is what I’m doing and it seems to work fine.

I’ve created groups in AD for my spark users

I have a logon script that runs and checks the group membership.

if they are a member of the spark users group, then they get a default spark config, and a spark shortcut to their “startup” folder.

Thats pretty much it. I’ve also configured SSO to make things easy for the users.

Thanks Speedy,

I am not very familiar with the workings of Spark, but what config file are you referring to and how do you initially install the Spark Client on the Terminal Server and what options do you choose?

There are only several people on this terminal server that need to see and use the Spark client so i want to make it totally transparent to the rest of the users unless they are in the AD group that is allowed to use Spark.

Would you mind sending me what you have in your login script for your particular Terminal Server?

Thanks

TR

its pretty easy… install and configure spark with your user account. DONT select the “start spark at startup” options. After you configure it the way you like, copy the spark.properties into a folder that end users can read from. Here is a snip from my logon script. “ifmember.exe” is a free tool in either the windows 2000 or 2003 resource kit and can be downloaded from MS

rem Auto Start Spark by adding to startup menu
Ifmember "App - Spark"
if NOT ERRORLEVEL 1 goto NoSpark
If NOT exist “C:\Documents and Settings%username%\Spark” MD "C:\Documents and Settings%username%\Spark"
IF NOT exist “C:\Documents and Settings%username%\Spark\spark.properties” copy “C:\UserSetup\Spark\spark.properties” "C:\Documents and Settings%username%\Spark"
copy “C:\UserSetup\Shortcuts\Spark.lnk” "%userprofile%\Desktop"
copy “C:\usersetup\shortcuts\Spark.lnk” "%userprofile%\Start Menu\Programs\Startup"
goto DoneSpark
:NoSpark
del "%userprofile%\Desktop\Spark.lnk"
del “%userprofile%\Start Menu\Programs\Startup\Spark.lnk”
:doneSpark

Thats pretty much it.

Hi Speedy,

I tried setting up a script just like you indicated below and the process does not work like i expected. The batch script works correctly as it places a shortcut on the desktop of those who are authorized to use it; but all users when logging in still get Spark launching automatically even when i have specified during setup as Administrator to not create shortcuts, program groups for all users.

I am not sure what i am doing wrong.

I have specified in the default spark.properties file startOnStartup=false but it does not work. This only seems to work once the user has successfully logged in and unselected ‘launch on startup’. This would be fine except not all users on the server have Spark accounts. Hence the point of not having it pop up at all for most users.

Any help would be appreciated

TR

sounds like you have a registry entry somewhere. scan your registry for spark.exe. I can’t remember the key, so you may want to post it before you deleted it.

Hey Speedy,

I found the issue. On a Terminal server it looks like the registry key for spark that needs to be deleted or edited is HKCU/Software/Microsoft/Windows/CurrentVersion/Run and not HKLM/Software/Microsoft/Windows/CurrentVersion/Run

Sincerely

TR

good to hear that you got it worked out. is everything else working as it should?