powered by Jive Software

SASL plain authentication -> No response from the server (smack 3.0.4)

Hi,

i have read a couple of threads about gmail authentication (![http://www.igniterealtime.org/issues/images/icons/bug.gif!] SMACK-224 - related) - but it didn’t help me unfortunately …

i’m trying to authenticate with gmx (gmx.at) but no combination of sasl authentication, plain sasl authentication, non-sasl authentication, security mode disabled, enabled, etc. seems to work

packets sent:

tag … - but maybe it simply uses another auth protocol … i have no idea about that stuff unfortunately )

thanks,

herbert

http://goim2.sphene.net

What are you trying to do? I use gmx for email, and I’m not aware that they provide a XMPP (jabber) service at all (and I went to look again).

You can’t send/receive emails with smack.

lol, yeah … i didn’t know it either (although i’ve never used gmx) - before a user told me that my IM won’t work for gmx’s jabber server…

but see here: https://stpeter.im/?p=1866

or simply ask nc:

kahless@localhost ~ $ nc gmx.at 5222

kahless@localhost ~ $

so … my question remains … am i doing something wrong ? how can i connect to the gmx.* jabber servers with smack ? (PSI can do it, others probably too)

should i provide an example code or something ?

thanks,

herbert

Hah, you learn something new everyday.

Ok, to connect using plain-text and no SASL, I use

// turn off SASL
conConfig.setSASLAuthenticationEnabled(false);
// allow plain text
conConfig.setSecurityMode(
    ConnectionConfiguration.SecurityMode.enabled);

And you say you tried it… All that’s left is to ask the guys that run the server at GMX…

I still can’t find any trace of it on GMX, is it about the MultiMessenger? In which case they might be adapting the protocol to a more proprietary thing…

On heise.de, the commentaries mention it only works with new email accounts, not old ones.

I am already using the settings which you mentioned here.I am using smack 3.1.0. However, while authenicating with NonSASLAuthentication.authenticate() method, i get this message of “No response from the server.” after the IQ packet is sent to get the list of authentication protocols. What could be the problem ?

// turn off SASL
conConfig.setSASLAuthenticationEnabled(false);

// allow plain text
conConfig.setSecurityMode( ConnectionConfiguration.SecurityMode.enabled);