powered by Jive Software

Says server is added, but it's not

I have installed the asterisk-im module and have gone through the server setup process, multiple times, and each time it says: Server created successfully

However no server shows up in the list and I can’t go any further.

Asterisk 1.8.6

Openfire 3.6.4

Asterisk-IM 1.4.0

Asterisk-IM plugin is not in development for many years, so maybe it is not compatible with recent Openfire versions.

Oh…is there a replacement?

Sorry, don’t know of any replacement.

your adding the wrong IP address for your server.

Try these:

Your domain name: mydomian.com

Your IP: 12.34.56.789

or the Lookback (which worked for me) 127.0.0.1

So should look like:

Server Name: asterisk

Server Address: 127.0.0.1

Port: 5038

Username: admin

Password: amp111

**Note: User name and passwords are the defaults for Asterisk.

All the info needed here can be found at /etc/amportal.conf.

I know this is an older message, but I was having the same issue and located the answer in a book.

Sometimes, when using Embedded Database, the server we just added will not be listed as shown in the figure above (although the message “Server created succesfully” does show up). This can be corrected simply by running the following two commands (in the Linux shell as root):

perl -pi.bak -e ‘s/(.serverName.)/ serverName varchar(255) not null,/’ /opt/openfire/plugins/asterisk-im/database/asterisk-im_hsqldb.sql

service openfire restart

2 Likes

Thanx, it works!

Hello All,

I have installed and running asterisk IM but when I add server the server icon doesnot turn green and nothing works.Please help me or give a link of video tutorial on how to set up openfire asterisk.

My settings are as follows.

Server Name-asterisk

Server Address- my local ip(124.153.121.202)

Port-5038

username-admin

password-amp111

Please help me in this regard.

I tried the Perl command in Windows after installing a couple different Perl versions. The -p option is different and there seems to be no equivalent based on the older Perl implementations. Is there another way to perform this same update? Perhaps manual steps using a database editing tool like SQLite Expert (SQLite Expert)? Otherwise, is there a suggested version of Perl for Windows?

Open openfire/plugins/asterisk-im/database/asterisk-im_hsqldb.sql and replace the “servername” line with the above string.

I wonder whether also other databases / database scripts have this issue.

OK, so I opened it with Notepad++ and this is what it says, without any editing:

It’s been ages since I studied Perl, and less time since I used sed, but I believe the line given would have me only removing the word unique, correct?

Right.