powered by Jive Software

Search Plugins problem

Hy all, I’m new user of Openfire. I installed version 3.4.3 on a freebsd (how simple and easy it was instead of jabberd2! :slight_smile: ) My users members are retrieved from an ldap server. I installed Search Plugin version 1.4.1 for my user to easily add new contact. My problem is that in the Administration Console , Search Properties, Searchable Fields , I don’t have any checkable box… I just can see : Use the form below to enable which fields users can search on. - Enabled Fields… And no fields behind!? If I try to search a user with * for wildcard, I don’t see anybody. Can someone help me please? Thanks a lot. Best Regards.

Hi jc,

Welcome to the Openfire community. When you say the search doesn’t work, are you using the Admin Console or a client? Also, are there any errors in your logs?

Thanks,

Ryan

Thanks for your reply!

Well you are true it wasn’t so fine explained.

In the Client (I use psi) in discovery service, i can see the "User Search, I i make search I have no result withot full jid or using wildcard.

In the Admin console : User & Groups Tabs, I have “Search a user” on the left frame. I works but no wildcards are enable, you must enter the good and complete jid.

I think, “search plugins” have added a new “Advanced User Search”… It accept wildcards… but it doesn’t give any result also with the good jid.

Any action I mention here did result in any change on my openfire log files…!!

I could be that the server did not install the search plugin correctly or did not complete the install. First try to reboot the server then check to see if the plugin has the search field options for you to configure. This is found on the main Server tab (Server - Server Settings - Search Service Properties). This needs to be configured for it to work correctly.

If that does not work stop the server delete the search.jar file and the search folder from the Openfire plugins directory. Then restart the server and install the plugin again.

Thanks again.

I still got the problem.

I reinstalled cleanly with the method you mention.

I’ve got the “Search Service Properties” in the Server Settings of the Admin Console. I can configure it… But i think not fully : there’s three things to configure :

Service Enabled -> Disable or Enable

Service Name -> Search .domain.com

Searchable Fields -> … Mine is empty… I just can see down there "Enabled

Fields" … and not any fields or check box to write or configure is listed behind it???

When I restart the Plugin, my log files don’t change. And I still can’t see anything behind “Searchable Fields”.

I don’t know If there is a solution. I think so!

My purpose of adding this plugin was to give a solution to users to easily find and add to roster new contact of ther choice. Is there a way to create such a directory which includes every members registered on jabber ?

I know I can use an xml file with psi client with the list of users… but that’s not the way I like to do. I would appreciate if they have the choice who the can talk with.

Thanks a lot.

Hi jc,

It sounds like the plugin is installed correctly so I’m wondering if the problems you’re seeing is related to how you have your LDAP settings configured. Are you using Active Directory or some sort of other LDAP system?

Thanks,

Ryan

Hi Ryang,

I use an openldap server to authenticate my user and admin.

We can authenticate and connect to the jabber server without problems. In the “Users/Groups” tabs of the Admin console, I can search with success a users with using “Search a user” by writing the exact UID. In the “Advanced Search”, it doesn’t works…

Here is what I can see in the “Advanced Search Properties” .

I tried to modify my ldap configuration in openfire… without success… there’s nothing which seems to be problematic. My users can login, they can chat… but I still can’t Search for users. It gives no result via psi client and also via admin console in "advanced user search "

Is there any other way to search /see or list users who can be added to roster? My purpose is to create a directory accessible for all users on jabber to add easily contact of their choice. It’s for an internal use only.

Thanks a lot.

Hi jc,

That’s very strange… if you login to the Openfire Admin Console and go to Server -> Server Manager -> System Properties, do you have a Property Name called, “plugin.search.excludedFields”? Also, if possible, would you post your conf/openfire.xml file (with any passwords X’d out) please.

Thanks,

Ryan

Hi Ryang,

I have a “plugin.search.excludedFields” … but there is not value for it, is it normal.

I have added my configuration file.

Thanks for your help.
openfire.xml (4325 Bytes)

Hi JC,

Looking at your config file it appears your entry is not quite correct according to the LDAP Guide. You should try either removing the entry or altering so it maps your Openfire/ldap fields properly, which I think would look something like:

<searchFields>Username/cn,Name/displayName,Email/mail</searchFields>

Give those suggestions a try and see if it fixes the searching issue; just be sure to shutdown Openfire, make the changes and then start Openfire so the changes take effect.

Thanks,

Ryan

1 Like

Great!

Thank you Very much for your help, it works really fine now!

It will learn me to RTFM… What you didn’t simply answer me. Thanks again.

Best Regards.

Cool! It is great to hear that the search is now working for you.

Cheers,

Ryan

This worked for me as well! thanks very much for the great followthough on this issue. I’m not sure what made the changes to the config.xml, but it was set to just Users and wasn’t searching my active directory.

thanks again!

Hi:

I too had same issue and this thread helped me to solve it!!..thanx @Ryan Graham

I Did following thing to solve…

first I added " Username/uid,Name/cn,Email/mail " in server manager -> system property -> ldap.searchFields

But It didnt work after that I uninstalled openfire completly removed openfire folder from /opt/openfire

installed again…while initial setup I provided Username/uid,Name/cn,Email/mail while configuring LDAP. After configuration it started working fine!!

Hello! I replaced the line in the file. But the search still does not work

I also tried to roll back to the version of the plugin Search 1.7.0 also did not help.

Prompt please, in what there can be a problem.

I tried spark_2_6_3, 2_8_3…

Windows server2012r2x64

OpenFire 4.1.4

Database SqlServer 2014

Users cling through Active Directory

Thank you!
openfire.xml.zip (1926 Bytes)