Search result shows usernames instead of displaynames

Hi all

I’m using Openfire 3.10.2 + Spark + LDAP + SSO on a Windows 2003 Domain Level (Openfire Server Windows 2008 R2, Spark client W7 Pro). I’ve tried and I’m using auto populate AD users using some groups, but I don’t want to add all users. So, I want to use the ‘Search contact’ option but at search results Spark is showing username (samccountname@xmpp_domain) instead of Displayname.

Any idea for changing this? My users doesn’t know other users’ samaccount so they cannot find them

Thanks in advanced

search should return the following when using the default settings.

JID, (in your case, its samaccount@xmpp domain )

Username (samaccount)

Name (This should be Display Name)

Email (Email addresses)

Is this not the case?

You can hide the username, name, email from being searchable by unchecking the boxes within openfire admin page, but this may limit the search results.

Hi Speedy,

thanks for your quick reply. You’re very speedy

I cannot see what you’re saying. Attached snapshot:


Where is your “Customize search” admin page ? I cannot find it at Openfire admin website

Hi again

I’ve to readd Search plugin. After that, I can see the ‘Search Services Properties’ page but at Service Name I can read:

Search service Name:search.sparksrv.mydomain.local (sparksrv.mydomain.local is my server FQDN)

How to fix it? I tried to modify xmpp.domain (also server FQDN) but after modifyng it I cannot login anymore. I’ve to modify openfire.xml and set Setup to false.