powered by Jive Software

Seeing offline Group when Group Offline Users is not checked

I am having the following problem, and perhaps this is expected in Spark, but, I am seeing a group called “Offline Group” even though I have unchecked the group offline users option. Otherwise, everything appears fine. I have my groups, which are AD groups, and the users, but just cannot get rid of that offline users group. I want users which are offline to still be in their respective group.

BUT, if I check ‘group offline users’, and then uncheck it, it appears how I want. The offline group is no longer there. Then when I log out/log in it is back???

<usernameField>sAMAccountName</usernameField>

<searchFilter>(objectClass=organizationalPerson)</searchFilter>

<groupSearchFilter>(&(objectClass=group)(name=Openfire**-**))</groupSearchFilter>

So all users in my basedn are shown in users and any group that begins with "Openfire - " is in my group summary. Just cannot seem to get spark to work as expected.

I am assuming you are using the client on a windows machine. What version of the client are you using? It should not appear if the option is not selected and it should be retained between launches. This is entirely controlled by the client. It could be you have a corrupt client setting folder. Try quitting spark, goto your profile folder and delete the spark folder. Restart spark and set the settings again. Also are you using windows look and feel in the spark settings.

Yes, clients are all windows. I am testing with a small group of users. I’ll attach what I see. Its the newest client, 2.5.8. Just that setting is not retained. I see “Offline Group” but if I check ‘group offline users’ and then uncheck it, it looks how I would expect. I have deleted that folder, it was recreated and same problem persists, for all of us testing, which either means the client is bad for us all, or something is causing this on the server side?

‘Use system look and feel (requires restart)’ is NOT checked. I checked it, restarted, same problem and the client looked worse, as there were extra spaces between the roster people.


Did you use the MSI installer or the EXE installer? I know it seems like a dumb question. If i were to guess you used the MSI.

spark_2_5_8.exe

Now that is odd. I used the exe as well and can not replicate your error.

Now if only my threads would get more people involved we might get somewhere. Thanks for your help as always. Well, hopefully my screenshots illustrated the problem clearly. It happens on every client connected to this server. Some of the users have their my documents and desktop redirected, others, including myself do not. Delete the spark folder, cleared all the db roster and group tables, etc. Just cannot get rid of that offline group.

Is this the client you use on all workstations? With all these little problems I am slowly realizing we might have to go another route. I wish there were more enterprise looking clients out there. For my taste, spark definitely looks and feels the most professional, but is just lacking some of the features I need…

we use spark 2.5.8 on all 200 computers in our company. this issue has never been reported to me. we only have 2 minor issues. occasionally the client will have a NPE error and can not send or receive chat (fixed by exiting and reloading spark) and we can not see gateway avatars (which only affect 8 users that are allowed to use gateways).

I just seems as though your spark settings are not being preserved in the profile. The settings for the groups are stored in a file called groups.properties found in the root of the spark folder in your computer user profile folder.

I would agree, except that the ‘show empty group’ setting persists after closing and reopening spark. Is that setting contained in group.properties as well?

My groups.properties looks like this:

#Tracks the state of groups.

#Wed Mar 26 08:18:21 MDT 2008

Operations\ Team=false

Information\ Technology=false

Information\ Systems=false

Offline\ Group=false

Unfiled=false

Nothing I do to the show offline group checkbox makes a change to this file. What does the ‘false’ mean? If I check it and close spark, it says false, if i uncheck it and close spark it says false…Cannot seem to make that file change at all…

This all brings up a separate question:

how is the userprofile variable controlled? For example, I have My documents and desktop redirected to F:\redirected. But, when, from a cmd prompt, I echo %USERPROFILE%, I get c:\users\jeff. But, the spark settings folder is in f:\redirected.

How then does spark put its folder anywhere other than c:\users\jeff\spark? How does it get put in f:\redirected if userprofile points to c:\users\jeff?

I don’t think this is related to my problem per se, because a user with his folders in the default locations has the same problem.

My Offline group is set to true. You are right though, any changes i make in the program are not reflected in that file. I am getting more confused as we dig further. That is not good

Reinstalled spark 2.5.8 on a clean windows xp installation using this time, spark_2_5_8_online.exe, and the same problem exists. When I start spark, if group offline users is NOT checked, it still has an offline users group. If I check group offline users and then uncheck it, the offline users group does NOT appear. If I close spark and then reopen it, the offline group is back, but group offline users is still unchecked. Can a developer please respond? Why would this happen? I can recreate the problem on any workstation and with every user. On vista, XP and Vista x64 using spark_2_5_8.exe and spark 2_5_8_online.exe. Happens with users whose my docs/desktop are redirected to
server\redirected%username%\ and with users who have no redirection at all. No change I make to the preferences in spark are reflected in groups.properties. This setting particularly does not change regardless of what I check/uncheck:

Offline\ Group=false

Look at your spark.properties file and make sure this entry is set correctly. If its set to “true” then you may have permission problems as this file gets updated when spark exits with your current settings.

offlineGroupVisible=false

Not a permissions problem. Every other setting I try works and retains after login/out. Just this one. I can modify that setting to true and false and when I start spark the change is reflected in the check box for group offline users. i.e. if I change the setting to true, save the file, start spark, group offline users is checked and vice versa. But, with it set to true or false, the offline group still appears. So that file is getting the changes saved, but the change is not reflected in the roster window unless I check group offline users and then uncheck it. Then is is ‘correct’ until I log out and back in. Really strange. Something with spark and apparently just in my environment. Guess I’ll just not care about this bug and focus on something else.

This is a long standing issue.

My first report: http://www.igniterealtime.org/community/message/143512#143512

After site migration to Clearspace i have created another thread for that and related issues: http://www.igniterealtime.org/community/thread/29149

SPARK-448 seems to be a workaround for that problem and is highly voted, but i just cant understand its Description (“the current behavior” part). Maybe LG should make it more clear. After some time i started to think that “Group offline contacts” unckecking wasnt intended to hide Offline group at all. So i have created my own JIRA ticket SPARK-928. Simply a checkbox to hide Offline group, no matter what other settings would be. Though know i’m convinced again it’s a bug with saving settings. But of course only Derek (former developer of Spark) can explain that behavior. You can get rid of the Offline group by unchecking “Show empty groups”, cause Offline group is empty one. But then you wont see any empty group.

I dont believe this (or bunch of other) issue would be fixed soon… But maybe this should be refactored from the ground. I dont see much usefulness in Offline group. Other clients just show all contacts in their groups and have an option to “Show only online contacts”. Simple. More than that, i prefer contacts to be sorted alphabetically, not grouped by online/offline status. SPARK-929

Personally i just dont pay attention to that group anymore, it’s collapsed and on the bottom of my long long roster, so i dont bother.

UPD: by the way, after you get rid of Offline group by checking/unchecking “Group offline contacts”, try checking/unchecking “Show empty groups” and you’ll get Offline group back. Something is totally broken there…

Glad to hear that its not just me. Thanks a lot.

hello all,

i have the same issue with spark in our every windows xp client machine as jeffrey has described.

any spark developer came to the solution then please guide me.

usig spark 2.5.8(windows xp) with openfire 3.6.3(fedora10)

Please try 2.6.0 beta 2. It’s already fixed in there.