SEP Small Business Edition blocks Spark from connecting to Openfire

I’ve had Spark/Openfire running for a month with no issues. Today I decided to update my Symantec to the new version and make it cloud based. Once I finished the install and setup of the new Symantec I was no longer able to connect to the Openfire server using the Spark client and receive the message “Login Error: Can’t connect to server. invalid name or server not reachable”.

I’ve tried using the SEP online management console to add exceptions to the firewall and to set the Spark program as an allowed program but to no avail (I even restarted the server and client computers to cover all bases).

Any help would be greatly appreciated.

We are using the latest SEP version (12.1 RU6 MP5 - 12.1.7004.6500) in our network and haven’t seen such issue. Clients are using Full Install (with a firewall and proactive threat protection). The server hosting Openfire only has a Basic Server installation of SEP. Maybe that’s Symantec’s firewall and not the threat protection itself blocking it. You can try adding a rule to let through connections on port 5222 to a server hosting Openfire or maybe disable SEP’s firewall on that machine for a test. If nothing helps, i suggest also asking on Symantec’s forums (or file a support ticket).

Thank you wroot for the quick reply. We were using that version of SEP previously and didn’t have any issue either. We are now using the upgraded version which is “ - Endpoint Protection - NIS-”. This issue didn’t start until I updated SEP, so I uninstalled SEP from both the server and client computer. Then I uninstalled Openfire from the server and Spark from the client computer for testing.

I just installed a fresh copy of Openfire on the server and re-setup everything (users etc…), then installed Spark on the client computer and entered the username, password and server name like I just set it up on the server. So everything is a clean slate without SEP installed.

Unfortunately I’m still receiving the “Login Error: Can’t connect to server. invalid name or server not reachable”. Nothing else has been changed on the server or the client computer so I’m currently stumped on what the problem could be.

Any other suggestions?

Problem Solved!

It looks like Windows Server 2008 RS blocks Openfire even if you add it to the allowed programs. So I did the following which resolved the problem.

  1. Open Windows Firewall and click on “Change notification settings”.

  2. Under domain network settings put a check mark in the box beside “Notify me when Windows Firewall blocks a new app”.

  3. Click okay and restart Openfire

  4. When Openfire restarts a box will pop up for the windows firewall asking if you want to all the program click yes

This worked for me and I hope it helps someone else as well.

Well, i did this manually when setting up Openfire on our WS 2008 R2. Just added the rule letting through an incoming connection from 5222, 9091 ports. Maybe you had SEP with firewall installation on the server before and Symantec’s firewall wasn’t blocking it (it also disables Windows firewall i think).