powered by Jive Software

SERIOUS issue with Spark and Windows XP x64

Looking at the screenshot Spark looks to be a great program. This bug should be fairly easy to fix. I have had this bug occuring before when using a messenger client (also programmed in java) called mercury.

I have the 32bit JRE installed on my computer (latest) although Spark installed its own to the program folder. ALL other programs run fine except the one listed above (e.g Jive Messneger runs fine)

Spark opened and everything was fine. The explorer crashed. I opened Task manager and that crashed as well.

To the standard user this would look like a normal crash. However I have had this happen to me before and it appears to be a java problem. Something in the code or java communicate with something in Windows, causing it to crash.

It may work if I were to install the 64bit JRE and then remove the 32bit one that comes with Spark.

Hopefully someone knows how to fix this so that I can get it working. It isnt worded very well but hopefully you can understand it!

Thanks

huwnet,

That definitely makes sense – the 64 bit JVM is different than the 32 bit one that we ship with Spark. Can you try the following?

  1. Make sure you have JDK 1.5.0 for x64 installed.

  2. Delete the “jre” directory out of the Spark installation.

  3. Set a JAVA_HOME environment variable that points to your Java installation.

Then, attempt to start Spark and see how it works. One thing we could do is start shipping a version of Spark that doesn’'t include the JRE.

Regards,

Matt

Matt,

I’'m having the same issue with Windows 2003 x64.

When I follow your above instructions Spark says that the JVM is damaged.

The version of Java I’'m using is 1.5.0.05.

Is there anything else I can try?

Thank you,

Max

mgoldfarb, can you give me the link to the x64 version of java?

I need to reinstall it but I am having trouble finding the right version on the Sun Website.

Thanks

Sure.

Go to http://java.sun.com/j2se/1.5.0/download.jsp and click on the “Download JRE 5.0 Update 5” link.

The x64 version is all the way at the bottom (Windows AMD64 Platform).

Ah yes thanks!

OK I have installed it, set the environment variable to the x64 version.

As usual the desktop just frooze up.

I tried to look at the java process in task manager but as that was frozen as well I dont know if the 64bit java was even initalised.

I dont know what timezone you guys work in but I might be able to set up a 64bit virtual machine with remote access between 4 and 9 GMT most days of the week

Still havent managed to get this resolved.

Thought I would bump this thread as there as been a lot of x64 talk in the Wildfire forum.

Has anyone managed to run Spark successfully on x64 (XP which uses the same core as 2003 server x64 so it should work with the same settings) using either the 32bit or 64bit version of java without it crashing?

I have tried setting the java_home variable but it will still crash

Just updated from Spark 1 > 1.0.2 and now everything works fine.

Don’'t know what the problem was

We were using a callback mechanism to tie into system idle, which will fail on X64. I added new idle checking without callbacks and tada

-Derek