powered by Jive Software

"Server does not support Vcards. Unable to save your vcard" when trying to add an avatar

I am using the latest versions of spark and openfire and get “Server does not support Vcards. Unable to save your vcard” when trying to add an avatar. I tried using a gif, a jpg

Any ideas?

Are you using LDAP to populate your user list? If so you need an additional plugin to enable vCard avatars. I have attached the plugin.
ldapvcardavatar.jar (6122 Bytes)

That is great! works! Thanks!

ps-i searched this site and couldn’t find this (prior to posting)

Let me show other “alternative way” to make this integration work:

In my case, i use wildfire 3.1.1, and this plugin (ldapvcardavatar.jar) dont works, then i use this in my wildfire.xml:

<provider>

<vcard>

<className>org.jivesoftware.wildfire.ldap.DefaultVCardProvider</classNa me>

<className>org.jivesoftware.wildfire.ldap.LdapVCardProvider</className& gt;

</vcard>

<user>

<className>org.jivesoftware.wildfire.ldap.LdapUserProvider</className&g t;

</user>

<auth>

<className>org.jivesoftware.wildfire.ldap.LdapAuthProvider</className&g t;

</auth>

<group>

<className>org.jivesoftware.wildfire.ldap.LdapGroupProvider</className& gt;

</group>

</provider>

In this way, you can make searches in ldap (at botton of the spark window screen) and set the profile free of the ldap (in my case, ldap dont have informations to show about all users, and users can edit their profiles as they need). Note that the order of the lines in bold have to be as i show here, other way it wont works.

I know thats not the best solution, but works for me and i want to share with others.

That is a very innovative solution for those users that use LDAP purely for authentication. I do appreciate solutions that think outside the box.

I get an error when trying to load this plugin:

2007.11.05 12:10:42 [org.jivesoftware.openfire.admin.plugin_002dadmin_jsp._jspService(plugin_002dad min_jsp.java:159)

] Plugin manager failed to install plugin:
Dc03\software\Misc\openfire ldapvcardavatar.jar

I was unable to upload this plugin, but was able to get to it load by placing the .jar file directly into the \OpenFire\plugins directory. Thanks to opie.

I recently upgraded to OpenFire 3.4.5 and my ability to change avatar stopped working. Same error you mentioned. I’m runing OpenFIre on Ubuntu Server 7.04. I even downloaded the ldapcardavatar.jar again, but same error.

Any ideas?

The plugin no longer works in current openfire versions as the feature is built in now. In your openfire admin site go to the System Properties, make sure ldap.override.avatar is set to true, delete all aspectes of the old plugin from the server the jar file and the folder it created, reboot the server, and your should be back in business.

Got it to work. In the system properties the ldap.override.avatar was missing. I had to run the LDAP connection wizard again, then go to the openfire admin page. Go to system properties. Make sure ldap.override.avatar was set to true. It reappeared as false. Changed it to true and now it works.

This worked perfectly!

Thanks…

I tried downloading and importing the plugin the the web admin console… when i upload it, it says it uploaded, but it never shows up…

Ive recently setup a new Openfire server V 4.2.3 and i have ldap.override.avatar set to true and i still get this error.