Hi everyone,

I’m getting some issues with sparkweb and i would need some help.First of all i’ve set up an openfire server on a windows pc and its working fine.

The major problem is that when i tried to connect to the server externally with sparkweb, i got a problem.In fact the problem is that on the sparweb page

the server is always pointing on even if in the html file ,i changed it to my server domain name.

Plz help me


I’d like to know this too.

post your sparkweb config files so we can look at them please

Hi everyone,

Here is my config file,

return {
server: “”,
connectionType: “socket”,
port: “5222”,
autoLogin: “false”
// policyFileURL: “xmlsocket://”

Am also using a dynamic DNS updater on my server as i don’t have any fixed ip address.

Thank you for your help.

I think it’s a caching problem. Try clearing your browser cache.

I made the cleaning each time but still having issue.Do you know a valid configuration so that external users could connect through the web?

No, i’m waiting for an answer myself (in the other thread). It looks like this is some issue with flash security, because it is working fine in localhost. But i can’t find clear information how should i config this crossdomain policy thing.

here is my config, which is also using a dyndns account

I’ve cleared my browser cache too, and i’m trying from different computers, all with the same results.

I cant get it to come up right either locally or the remote. (dont think that makes a difference)

try connecting to your sever once by changing the sever name that is displayed when you load the page. believe it or not the site has some sort of history capability. i do not know how they accomplish this but it does exist.

Hi everyone,

I’ve succeded in connecting to the Sparkweb, unfortunately only once as when i tried again, it was saying ‘‘Problem authenticating with the server or you are not authorized to perform this operation’’

It’s really weird…

Why the first time and not the others???

Here is my config

function jive_sparkweb_getConfig() { return { server: "", connectionType: "socket", port: "5222", autoLogin: "false" // policyFileURL: "xmlsocket://"

That seems to be a common problem. Change your connection type to http-bind and make sure the appropriate ports are configured.

xtopther5, this could be a connection problem as well. Flash is throwing unauthorised error if it doesnt get crossdomain file in 3 seconds. Well, i was told it works that way. So maybe you should try more times. Also, why is you PolicyFileURL line commented? You should remove those “//” slashes in the beginning of that line.

Hi everyone,

Can someone please post a valid configuration as example.

Thanks in advance