powered by Jive Software

Server not connecting to our asterisk

we are using openfire 3.6.0 with asterisk-im 1.4.0. openfire is on remote server and our asterisk server is internally behind a firewall. We cannot get connect or the green icon is not showing. It is a grey icon beside on server entry.

I’ve entered in the server name our asterisk is called, asterisk ip static ip, port 5038 and username and password. Which username and password do I use elastix or freepbx? Is it port 5038 or 5060?

From reading I see and I could be wrong the mysql tables for asterisk-im needs to reconfigure. I tried this which I found in the forums here but it did not work.

Please advise.

create table phoneServer (
    serverID bigint not null,
    serverName varchar(255) not null,
    hostname varchar(255) not null,
    port int not null,
    username varchar(255) not null,
    password varchar(255) not null,
    primary key(serverID)
);
create table phoneDevice (
    deviceID bigint not null,
    device varchar(255) not null,
    extension varchar(255) not null,
    callerId varchar(255),
    isPrimary int not null,
    userID bigint,
    serverID bigint not null,
    primary key (deviceID)
);
create table phoneUser (
    userID bigint not null,
    username varchar(255) not null,
    primary key (userID)
);
INSERT INTO jiveVersion (name, version) VALUES ('asterisk-im', 2);

I found the answer. In command for your asterisk, go to /etc/asterisk/manager.conf. permit=xxx.xxx.xxx.xxx/xxx.xxx.xxx.xxx (your asterisk ip and submask)

I followed the procedure u posted but it vain. I had another issue, when i entered the information for login in Red5 phone test page. I’m getting the error Registration failure:Time out. Can any one help how to login in to the Red5 phone and what details should be entered in the Red5 phone test page. sorry for my terrible english.

I am using the latest openfire 3.6.3 and asterisk-im. just install new openfire, did not do anything to openfire databases. But, for asterisk connection, where asterisk is install on your server you have to edit manager.conf file for asterisk. Here is another discussion that worked for me http://www.igniterealtime.org/community/thread/36135?tstart=0.