Server Running but no admin panel?


I am running ubuntu server edition 7.10. I have installed openfire (albeit an old version. couldn’t seem to get the latest one to work, although that may be due to this issue) and can connect to it through my admin logon via a jabber client. I managed to set it up, then when i rebooted the server I could still log on through my jabber client, but couldn’t access the web admin panel (port 9090). Get this firefox error:

Failed to Connect

Firefox can’t establish a connection to the server at

Though the site seems valid, the browser was unable to establish a connection.

  • Could the site be temporarily unavailable? Try again later.

  • Are you unable to browse other sites? Check the computer’s network connection.

  • Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.

I’ve also had issues whereby /etc/init.d and other sources say the daemon is stopped, and yet it is still running and i can access the webadmin panel? I’ve tried 9091 too, to the same error.

It just seems to be very random and completely unstable. I’m almost expecting to randomly get access to it again sometime later today…

Any ideas?

Hey Ewan,

Can you check for errors in the log files? You can also use netstat -a | grep LIST to confirm that some process is listening on ports 9090 and 9091. If you stop the server and something keeps listening on those ports then some other process is using them.


– Gato

tcp6 0 0 *:9090 : LISTEN

tcp6 0 0 *:9091 : LISTEN

I believe those are the relevant lines. So that means ‘something’ is listening on the port?

Which of the log files holds errors? There seem to be several in the directory with ‘error’ in the filename.

Thank you very much for taking the time to answer my query.

There seem to be several in the directory with ‘error’ in the filename.

error.log contains the latest errors, The file is renamed if it gets to large, so you will find older errors in the other files.

At best stop the server, delete all logfiles and start it again. Then you know exactly which errors happened. You should check all logfiles, not only error.log.

Hi there. As I predicted, later that day the server let me back into the webadmin interface again. It seems to be related to the (linux) server somehow. I’ve just tried upgrading it to the latest version, and now I’m back to the issue of it saying its running (ps aux also says this), but now I can’t access it at all, via jabber or http.

Log of error.log is below:

2008.03.04 16:56:45 [org.jivesoftware.openfire.filetransfer.proxy.FileTransferProxy.$ none: none


at org.jivesoftware.openfire.filetransfer.proxy.FileTransferProxy.initialize$

at org.jivesoftware.openfire.XMPPServer.initModules(

at org.jivesoftware.openfire.XMPPServer.start(

at org.jivesoftware.openfire.XMPPServer.<init>(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAc$

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConst$

at java.lang.reflect.Constructor.newInstance(

at java.lang.Class.newInstance0(

at java.lang.Class.newInstance(

at org.jivesoftware.openfire.starter.ServerStarter.start($

at org.jivesoftware.openfire.starter.ServerStarter.main($

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke($

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorI$

at java.lang.reflect.Method.invoke(

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)

Anyone know what’s going on here?

> none: none
> at

Is localhost defined as in your /etc/hosts file?

Check if something like this works:

[coolcat@sempron2800 ~]$ ping localhost
PING sempron2800 ( 56(84) bytes of data.
64 bytes from sempron2800 ( icmp_seq=1 ttl=64 time=0.073 ms
64 bytes from sempron2800 ( icmp_seq=2 ttl=64 time=0.079 ms
64 bytes from sempron2800 ( icmp_seq=3 ttl=64 time=0.078 ms --- sempron2800 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.073/0.076/0.079/0.010 ms

ewan@none:~$ ping localhost

PING localhost ( 56(84) bytes of data.

64 bytes from localhost ( icmp_seq=1 ttl=64 time=0.044 ms

64 bytes from localhost ( icmp_seq=2 ttl=64 time=0.064 ms

64 bytes from localhost ( icmp_seq=3 ttl=64 time=0.054 ms

64 bytes from localhost ( icmp_seq=4 ttl=64 time=0.054 ms

— localhost ping statistics —

4 packets transmitted, 4 received, 0% packet loss, time 3025ms

rtt min/avg/max/mdev = 0.044/0.054/0.064/0.007 ms

And yes, hosts file says is localhost. It’s a virtual server… if that helps?

Thanks again for helping me with this, it’s much appreciated.

I had this same issue where the admin console would only listen gratuitously on IPV6 not IPV4. I fixed it in my case by disabling IPV6 support on my machine and rebooting.

Do you have any sort of firewall running? I don’t know ubuntu, but in redhat you can run system-config-securitylevel and open those ports. Otherwise you get squat. I’m sure a quick google will tell you how to open the ports on Ubuntu.