powered by Jive Software

Server to Server Communication

I am running two Jive Messenger servers and wish to setup server to server communication between them. I have ports 5222, 5223, and 5269 fully accessible on both servers. I have successfully established the connection one way, however, I am having difficulty establishing the complete two-way connection. Server A indicates an established Incoming connection, and Server B indicates an established Outgoing connection. As far as I can tell, both servers are configured the same, allowing server to server access from anywhere. I am using Psi to connect to both servers simultaneously. Remote contacts on Server A indicate Subscription as ‘‘both’’, where remote contacts on Server B indicate Subscription as ‘‘from’’ only. Messages can be sent from Server B to Server A, but not from Server A to Server B. I’‘m sorry that I haven’'t provide more detail than this, but I will provide anything suggested that might be helpful. If someone could help me to at least pinpoint the problematic server, I would be most appreciative. Thanks in advanced for your support.

Hey DJ,

try this:

telnet jabber.server.com 5269

type hello " ?

If not you either have DNS issues or firewall issues.


It connects, but doesn’'t echo anything back, regardless of what I type. It looks like it must be normal however, as it does this even on the local machine.

I would like to note that the servers I described above are configured under the same primary domain name. For example, Server A would be server1.com, and Server B would be server2.server1.com. After changing Server B to its own domain, say server2.com, the server to server connections indicated “Both” in the Jive Admin interfaces on both servers. However, messages can still only be sent from Server B to Server A. Nothing changed here. Regardless, it would be nice to have both servers running under the same primary domain as they were before. Thanks again for your support with this issue.

Any ideas, anyone? Thanks again.

Hey djholt,

I never tried that configuration but it should be working fine. I have a couple of things I would like you to test.

  1. Use the IP address of the machines as hostnames. Let me know if it works fine.

  2. User xxx.server1.com and server2.server1.com. Let me know if it works fine

  3. Use server1.com and server2.server1.com (like you are doing now) but first turn on the debug log in the Admin Console so we can collect debugging information. If you see a “Both” type in the sessions list then packets should be flowing correctly. Any message in the error/warn log files?


– Gato