powered by Jive Software

Server won''t start

Worked fine for two days. Restarted computer for the first time, here is the error message when I go to admin via web port 9090.

Openfire Setup

Error: Can not proceed with Openfire Setup.

Your current installation fails to meet minimum server requirements - please see the checklist below:

At least JDK 1.5

Servlet 2.3 Support

JSP 1.2 Support

Openfire Classes

Home not found. Define system property “openfireHome” or create and add the openfire_init.xml file to the classpath

Please read the installation documentation and try setting up your environment again. After making changes, restart your appserver and load this page again.

How do I restart the setup or fix this problem?

Thanks.

Hi,

I guess that you are using Linux and the supplied start script which fails to change the directory to $OpenfireHome/bin before trying to start Openfire. Modify the the start script so that it does this or take a look at http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide and http://wiki.igniterealtime.org/display/WILDFIRE/SimpleStartScriptforOpenfire

I still hope that these scripts will be used for the next Openfire version.

LG

If you are running a redhat or redhat like system and installed 3.3.1 via RPM, there’‘s an issue where JAVA_HOME gets set in the environment and the “let me go find a good JRE” code doesn’'t execute. For the moment, you can get around that by editing /etc/sysconfig/openfire and setting JAVA_HOME explicitly to /opt/openfire/jre