powered by Jive Software

Server2Server connection trouble

Hello!

I have strange behavior my Openfire-servers when I’m trying to connect each other. There are two different servers on two different virtual machines. Both of it are Openfire 3.7.1 on Debian Squeeze, NTLM-authentication in AD, but two different domains. There is no any firewall between the servers and iptables has accept policy. Each server has record about another one in Server2Server menu. All security stuff (TLS, DialBack) is turned off. All names is resolved correct. Connection is not established, but in log there are records, that “Plain connection to mydomain.loc:5269 successful”.

Finally, server tells "OutgoingSessionPromise: Error sending packet to remote server:

java.lang.Exception: Failed to create connection to remote server"

and breaks the connection.

The part of Debug log is attached.

Have no idea what to do. Will be grateful for any help.
debug.txt.zip (2412 Bytes)

Sorry, forgot to show log from other server. There are only two records:

2012.07.25 18:11:54 org.jivesoftware.openfire.net.BlockingAcceptingMode - Connect Socket[addr=/10.0.0.2,port=41890,localport=5269]

2012.07.25 18:11:54 org.jivesoftware.openfire.net.BlockingReadingMode - Logging off mydomain.loc/8b37f07b on org.jivesoftware.openfire.net.SocketConnection@66441260 socket: Socket[addr=/10.0.0.2,port=41890,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@64cf020d status: 1 address: mydomain.loc/8b37f07b id: 8b37f07b

So your DNS resolves the FQDN shown in “from” and “to” fields?

Solved problem earlier, but thought in this way. When I placed record about other.domain.com in /etc/hosts on the openfire.mydomain.loc and turned on DialBack, everything worked. It was unclear why connection was broken in spite of “Plain connection to mydomain.loc:5269 successful”.

On the other hand the question about connection without security options is opened. Tried to turn off DialBack and TLS then connection was torn again.