powered by Jive Software

Service not running after install

Got the Jitsi plugin after openfire uprgade today. I’ve looked at the howo document around here and did what is listed there including restarting. Nothing works though. No service is listening on port 7443 (netstat control, nothing listening) and the URLs in the plugin help page also do not work.

Is there anything special you have to configure to make openfire actually start the jitsi plugin service?

There is nothing in the admin panel of jits that suggests you need to activate it somehow. Something I’m missing?

Ports 7443 and 7070 are the http-bind ports. If they are not working. then you have a problem with your Openfire install. Check your log files. You might need a restart

I have restarted already a couple of times. In the logs I see nothing strange:

WARN:

2014.05.04 12:48:17 JitsiVideobridgeStack - using default tls security policy

2014.05.04 12:48:19 JAIN SIP 1.1 - using default tls security policy
2014.05.04 20:39:57 JitsiVideobridgeStack - using default tls security policy

INFO:

2014.05.04 20:39:56 org.jitsi.videobridge.openfire.PluginImpl - Initialize Web App jitsi

2014.05.04 20:39:56 org.hibernate.validator.internal.util.Version - HV000001: Hibernate Validator 5.0.1.Final
2014.05.04 20:39:57 JitsiVideobridgeStack - the sip stack timer gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
2014.05.04 20:39:57 org.jitsi.videobridge.openfire.PluginImpl - Initialize SIP Stack at server.rptd.ch:5070
2014.05.04 20:40:40 org.jitsi.videobridge.openfire.PluginImpl - Native lib folder created and natives extracted

got to https://your_server:7443/

you should see

Openfire HTTP Binding Service

I’ve disabled this one due to security concerns. Why does jitsi require this?

web service for the jist web application.

If you have decided to disable it, then copy the apps folder to your own web server and create your own config.js file.

Is there an example config.js around somewhere?

https://community.igniterealtime.org/community/support/jitsi_videobridge_plugin/ blog/2014/02/08/configure-ofmeet-first-before-trying-to-create-a-videoconference