Service unavailable - Openfire 3.4.5 and JWChat-1.0beta3

I am using Openfire 3.4.5 and JWChat-1.0beta3.

I can see website at, but when I try to log in a window pops up and a message “Service unavailable”.

HTTP binding is enabled on port 8080. I found that if I enable Script Syntax BOSH and log in to I get

HTTP ERROR: 400 BAD_REQUEST, but when I dissable this option I get HTTP ERROR: 404 NOT_FOUND. In either case I still get “Service unavailable” error.


var SITENAME = “”;





When I go to or it shows me so I guess that this bit works fine.


RewriteEngine On

RewriteRule /jwchat/http-bind/

RewriteRule /http-bind/

<Directory /var/www/html/jwchat>

Options +Indexes +Multiviews


I also tried changing those but without success:

Edit jsjac.js and set

var JSJACHBC_USE_BOSH_VER = false; /* true; */

Edit jwchat.html and just before line:


Add this line:

oArg.authtype = ‘nonsasl’;

Log into OpenFire as an administrator and add two server properties:

xmpp.httpbind.client.requests.polling = 0

xmpp.httpbind.client.requests.wait = 10

I have been stuck with it for a long time now. Appreciate any comments. Please help!

exactly the same problem here with a new installation of Openfire 3.4.5 on a Windows machine.


The problem nags me too. Is it a bug or something?


do one thing edit it(httpbase) like this




and make changes in the “web.xml” file of “JWChat-1.0beta3\WEB-INF” folder like this

hope it will work