powered by Jive Software

Setting up Openfire and SSL

I have 4.4.0 installed and working properly, and am trying to set up SSL. I thought I had imported two certificates (more in a moment), but when I tried use access the secure admin console on port 9091 all I got was

�P (and a couple more charcaters which disappear from the rendered version of thiss message)

I tried working through the properties to make sure everything was in line (including resetting the passwords on all the store. Now I have no certificates (the ones I had just disappeared) and I’m still getting the odd Unicode characters

I’m obviously missing a step, but what? The 4.4.0 documentation has the SSL guide if you want to do it manually, by I’m trying to use the admin GUI

Last week, I was up to configure well known and successful Openfire jabber server with valid SSL certificate configuration. Initially I have had hard times trying to do it according to many howtos and forums accessible using google, none of which worked. Each of them referenced manipulation of java SSL keystore directly with keytool.

It did not work. It was waste of time. And if after many attempts all seemed good, asterisk throwed java exceptions, when accessing certificate management functionality of Openfire administration interface.

Despite all these troubles, setup of SSL certificates with asterisk is in fact very simple.

please share your wisdom!