powered by Jive Software

Setting up openfire on server 2008

Good Day

I’m wondering if anyone can help me, i have just upgraded my server and openfire installation from server 2003 to server 2008 (Openfire 3.6.3) and now in the setup i need to specify the database connection string (mssql). I have tried the same connection string as what i used on my server 2003 setup with no luck (//hostname:port/database_name. The mssql server is on the same machine so the host should be //localhost:1433/openfire or //127.0.0.1:1443/openfire or possibly the machine name //openfire:1433/openfire but none are able to connect. I have enabled shared memory, TCP/IP and named pipes on the sql server but still cannot connect. Is there something i am missing perhaps? a new security feature i am unaware of in server 2008 or a prerequisite i am missing before the installation? Any help appreciated.

what type of MSSQL is it, the full version or the express? If express did you install it as a default instance or a named instance.

I installed using the default instance of MSSQL 2005 express… i managed to figure the problem out though and it seems it was a firewall issue. I have created a whole batch of firewall “port” rules including one for the dynamic port of TCP/IP on MSSQL and now it connects… Thanks for you input.