Setup after install of 3.5.2, getting 'Access is denied' errors

I just installed openFire 3.5.2, and when running setup I get the following ‘Access is denied’ errors when trying to access files in C:\Program Files\Openfire\logs.

System in a PC running vista.

Any ideas would be much appreciated.

2008.08.06 20:18:08 Error occurred opening log file: C:\Program Files\Openfire\logs\debug.log (Access is denied)
2008.08.06Oep2 nfire 3.5.2 [Aug 6, 2008 8:18:08 PM]
0:18:08 Openfire 3.5.2 [Aug 6, 2008 8:18:08 PM]
20A08.08.06 20:18:13 Admnidmin console lsi console listneeitning at httng at http/::p/
2008.08.06 20:18:30 [org.jivesoftware.util.XMLProperties.saveProperties(
] C:\Program Files\Openfire\conf\openfire.xml.tmp (Access is denied)
at Method)
at Source)
at Source)
at org.jivesoftware.util.XMLProperties.saveProperties(
at org.jivesoftware.util.XMLProperties.setProperty(
at org.jivesoftware.util.JiveGlobals.setXMLProperty(
at org.jivesoftware.util.JiveGlobals.setLocale(
at org.jivesoftware.openfire.admin.setup.index_jsp._jspService(
at org.apache.jasper.runtime.HttpJspBase.service(
at javax.servlet.http.HttpServlet.service(
at org.mortbay.jetty.servlet.ServletHolder.handle(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage( 8)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.LocaleFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.PluginFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.AuthCheckFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(
at org.mortbay.jetty.servlet.SessionHandler.handle(
at org.mortbay.jetty.handler.ContextHandler.handle(
at org.mortbay.jetty.webapp.WebAppContext.handle(
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect
at org.mortbay.jetty.handler.HandlerCollection.handle(
at org.mortbay.jetty.handler.HandlerWrapper.handle(
at org.mortbay.jetty.Server.handle(
at org.mortbay.jetty.HttpConnection.handleRequest(
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:829)
at org.mortbay.jetty.HttpParser.parseNext(
at org.mortbay.jetty.HttpParser.parseAvailable(
at org.mortbay.jetty.HttpConnection.handle(
at org.mortbay.thread.QueuedThreadPool$

My first guess would be that the windows firewall is blocking the openfire server.

I was able to get openfire working but only after uninstalling, and reinstalling with the windows firewall turned off.

After it was installed and setup finished, as an experiment I thought I would try restarting the server with the firewall active.

Here is the sequence of actions:

I stopped openfire.

enabled Windows Firewall.

Started openfire

Errors occured as before with the ‘Access is denied’ errors.

Stopped openfire

Disabled Windows Firewall

Started openfire

Still got error messages indicating ‘Access is denied’.

It seems as though the recovery from the error condition is not working correctly. Shouldn’t I be able to start openfire after turning off Windows firewall. Or do I need to reinstall openfire everytime I hit this error condition? Is there some cleanup program I can run when openfire fails and I cannot get it started again?

Thanks in advance. I am a new openfire user, so I may not know all the usage details at this point.

I’m not sure if it’s Windows Firewall that caused the issue. I ran into the same problem on Windows Vista. I was able to “get out of” it by run OpenFire as an administrator. You need to right click OpenFire, select Properties, select Advanced, check “Run as administrator”. But that’s not enough since I already “damaged” the database. I also had to change “true” to “false” in openfire.xml, delete the old database and create a new one, then re-start Open Fire. This allowed me to do setup all over again without re-installing OpenFire. Hope this helps.