powered by Jive Software

Sharing desktop with ofmeet

Hi,

Great tool you’ve created! I’m trying to deploy it in my company, replacing Cisco hardware. I need to improve my general knowledge in this tool, but my first big question is about desktop share.

If I try to share my desktop with the first icon, the webpage “https://dev:7443/jitsi/apps/ofmeet/webrtcrequired.html” appears (“This service only works with Chrome. Download Chrome”). I’m obviously on Chrome, v37.0.2062.120 m.

It is normal? Or do I need to do something on my side?

Regards,

Ben.

Screen sharing does not work anymore with standard web pages. It is a new security design feature in Chrome. It only works from a chrome extension

Ok. So which chrome extension do we need to use to qualify for this extension ? Or it is a specific VideoBridge extension to develop?

You can take the jidesha chrome plugin, change it with your domain and publish it in the store.

More info: [jitsi-users] Jitsi Meet - Desktop Streaming Problem

Thank you for this info.

I’ve tried to generate a correct plugin, but it doesn’t work much better.

My server is local and named “dev”. I call the videobridge with “https://dev:7443/jitsi/apps/ofmeet/”. What do I need to set in the manifest.json ? Is “://dev/” right ?

Second question: It is mandatory to install the plugin from the store, or it should be working from a local directory ?

Well, not sure about the name. Not sure whether it should be publicly available. Well if it is in local directory there is no way to share it with other participants who want to enable desktop sharing. With older versions of Chrome there was a property to enable in the config and no need of this plugin, but it was removed and now this is the only way.