powered by Jive Software

SIP phone plugin configuration

Hi all,

I’m tryin the SIP with openfire and I’m confused because it seem to be a lot of way to be connected to a SIP server. First of all, i’m making my tests with an Asterisk (AsteriskNow release) but if my test succeed, the openfire will be connected to a Mittel SIP server, so I don’t think that the Asterisk IM plugin will be usefull for me.

I’m tryin the SIP phone plugin. I have added the SIP server IP and the voicemail number set in the Asterisk gui. After that I have added one of my users on the SIP phone mapping. I’m running the test and it answers me that the test is succesfull. But in the list of the users it is told that the user is “unregistered” (but it is enabled). How can I register it ?

My asterisk works, because I can make a phone call between two users connected with Xlite directly to the asterisk server. In order to validate the test, I want an user connected with Xlite to be able to connect a user connected with spark to my openfire server (with my phone mappings).

Thank’s for your answers.

GrK

PS : do I have to configure something into external components in the Server->server settings ?

Another question. Do my SIP server need to be DNS resolved ?

Ok … I found the problem !

I fact I was misunderstanding the difference between the Spark client SIP plugin and the SIMPLE plugin.

I you are, like me, not allowed to join the plugin repository with Spark, just Download the SIP plugin source (linked here), compile it and put it in your plugin directory of Spark.

GrK

Hey, let me get this right.

I’m also trying to get my sip phone plugin to work.

This is my setup: Openfire 3.5.2 with installed sip phone plugin and Spark 2.5.8. I have an account on sipgate.de - this account i like to use in spark. Sp therefore i go into the phone plugin to “sip settings” and entered the following (like told at sipgate.de)

Specify the hostname where the SIP server is running.

Specify the number to dial to access the voice mail.

Enable this field when you are using a STUN server.

Specify the hostname where the STUN server is running.

Specify the port where the STUN server is listening.

At “sip phone mappings” i entered the registered xmpp user and the SIP username and password provided by sipgate.de. If i click on “test” - i get an failure because of a wrong password - but it’s not wrong. At spark the phone component appears at enabled - also at the openfire backend. If i click “try again” in spark to connect my sip i get failed to start phone. Have i done something wrong? I don’t think that i need the asterisk im plugin nor a asterisk server because i like to use the server from sipgate.de

Thanks in advance!

EDIT: I’m running also the red5 Plugin on my openfire install but i disabled the phone component of red5 - " - Red5 Plugin will NOT appear as a phone component to Spark". I also disabled under Media Services the Media Proxy but nothing happen.

I tested the sip phone plugin with a clean openfire install. No plugins where install aside from the sip phone plugin and here it works! So why don’t at my productive Server? Firewall-Settings are all ok. Can it caused by any other plugin that i’ve installed?

Hi

I’m getting Reg.failure=Timeout in Red5 test page. pls post require info for login in to Red5 test page.