powered by Jive Software

SIP Phone Plugin + NAT

Hi,

I have spark 2.5.8 and Openfire 3.4.5 and SIP works fine but I can’t hear anything. This seems to be a NAT Problem. But we have WLAN phones in the same LAN and there it works fine. I have notice that they have an option to send a rport flag that allows a client to request that the server send the response back to the source IP address and port from which the request originated.

Is this or will it be supported in Spark?

1 Like

Actually,

SparkPhone always uses rport flag.

Best Regards,

Thiago

mhh, I have tried WengoPhone and it works fine with audio. But in spark I cannot hear anything and there are no configs where I can try some settings. What can it be?

I can call a phone in the same subnet but I also cannot hear anything in both directions. I think this is a local problem. But I can hear the dialing tone. can it be a codec problem? What codec is spark using?

I have the exact same problem and stand perplexed. I’m running Spark 2.5.8 and SIP phone v1.0 on Windows XP SP2 with all the latest patches. I double checked that the windows firewall isn’t activated. The only other thing that could interfere with the netwok stack is possible McAfee AV v8.5i

I have moved my workstation into the same subnet/VLAN as our Asterisk server and still see the same results. Note, the Asterisk, OpenFire and workstations are all on the same subnet.

I tcpdumped my workstation and the asterisk server. It seems like all the UDP5060 traffic goes through fine, but the Asterisk server is trying to send packets to my workstation on a random UDP port. My workstation sends back ICMP port unreachable to the Asterisk box.

Note, the Asterisk logs seem to indicate that the call is being set up properly from a SIP perspective.

I don’t think this is a NAT issue. Is there a “debug” mode for the SIP phone plugin in order to help investigate further? I’ll try and capture a full SIP and RTP session for you guys if you think this is useful.

Pat

So it works fine with another SIP phone/softphone but not Spark/SIP? Mine is working ok without anything different at the firewall than what I have for other phones. I think I would look at the SIP/mappings config and verify that it is correct. Can the OF server and the client both resolve the PBX hostname correctly? Using the same SIP-server, SIP-username, & SIP-authorization configured in OF should work on any other SIP device. I have a basic NAT setup with the UDP 5060-5064 and RTP ports forwarded to the PBX and firewalled.

I also am suffering from the same problem. NAT is not the problem as we run an asterisk server on the same LAN

as the Spark SIP Phone. We have a large number of Snom hardphones, and use other softphones with the same settings without any problems. I’ve tried forcing the ulaw codec as suggested elsewhere, but no joy.

Has anybody actually got this working?

Thanks,

Ben.

OK the problem is that the Spark 2.5.8 MSI is broken. Using the .exe version is fine, so I built my own MSI with WinInstall and it works ok.

However, when dialling from Spark, it continues to play ringback tone for a couple of seconds after the callee has picked up, which is rather strange, meaning you miss the first part of the audio.

Ben

Yep, that MSI is garbage. Anyone know if it’s going to be fixed?

Joe

Have the same problem here, but used the EXE and not the MSI.

I see the Spark client sending back a port unreacheable.

Does anybody have any suggestions?

All: Curious:

  • Do you use STUN?

  • QoS on any intervening routers?

  • In our installations, we’ve had positive results so far for local and WAN<->LAN connections

  • Are you able to try using an updated version of the SIP plugin and of Openfire itself?

I don’t know if this issue was resolved or not, but I will add my two cents.

The SIP protocol doesn’t like NAT by nature, and 99% of the problems described here are related to NAT. The scenario is exactly like this: SIP registration is successfull, you hear the ring tone, but when the other party answers, either you don’t hear them or continue to listen to the calling tone. This is a typical NAT issue.

If someone needs help on this, please feel free to email me.

Regards.

Does anyone have SIP Plugin working properly without any issues?

can you tell me how to setup openfire & spark with sip? thanks!