powered by Jive Software

Smack debugging in Eclipse?

I’m having trouble getting any of the debuggers to launch when running my application in Eclipse. I’ve added the “-Dsmack.debugEnabled=true” to the VM arguments. I’ve also included smack-debug.jar to the classpath. I can tell this does have some effect on my application since there are AWT threads that appear to launch, but for some reason XMPPConnection.connect() now hangs. I never see an AWT window.

Does anyone know if there is some sort of trick to using it within Eclipse?

Hi Karl,

I haven’t had any problems using the debugger while using Eclipse. Are you using Smack 3.0.4? Have you tried setting the debugger programatically by doing the following:

XMPPConnection.DEBUG_ENABLED = true;

Thanks,

Ryan

Hi Ryan,

Yes, I have tried this as it is suggested in the documentation. I also made sure it was done before instantiating XMPPConnection and calling connect. As mentioned in my first post, this does have some effect on my application. Basically, I see an AWT thread launch (which does not occur when debug=false), but no window ever opens, and the call to connect seems to completely lock up.

Also, yes, I am using Smack 3.0.4. I am also using Eclipse 3.3.0.

k