Small Business Server SBS 2003 Install with groups

I had an old version of Wildfire running on a few servers for a couple of years but have recently upgraded one to the lastest version of OpenFire 3.4.1 and now have issues with groups.

Running SBS 2003, i’m unable to get groups working, i have a security group call openfireusers configured in the default SBS Security Groups location and have added users to that group, i’m trying to populate Spark contacts with members of this group when a user logs into Spark, at the moment they see nothing…

During OpenFire setup everything test ok except the Group Settings which i just can’t get to work…

Does anyone have a working config file from an SBS 2003 setup i can compare group settings with?

I am having the same problem and I’m wondering if you ever solved it? I have Openfire 3.6.0a running on a Virtual Machine (winXP) and it can grab my users from our SBS2003 server via LDAP, but for the life of me I can not get it to see our groups. I would be happy if I could even make groups by hand in the Openfire admin section, but the create group section has the warning "Not allowed: the group account system is read-only. "

My main concern is being able to easily populate the contacts in Spark through a group since it would be silly to add everyone in the business by hand. Can anyone help me with this? I’ve tried to attempt some of the suggestions from this forum and none have worked. I also am a little unsure if the changes I have attempted to make to the openfire.xml file are working properly, since after I make a change,save, and reboot the server the property I was trying to change in the XML file is not changed when I view it in the System Properties section of the Admin Console.

Hope someone can help,


Can you post a diagram of your LDAP configuration and the baseDN you are using for openfire?

Here is a diagram of our AD setup, it’s the defualt for SBS setups. The baseDN that I am using is ou=SBSUsers,ou=Users,ou=MyBusiness,DC=myDomain,DC=local and that works in so far as being able to pull in users. However, none of the settings I have tried have worked to get my security groups listed. Thanks for any assistance.

Ugh, of course 2 seconds after I post this I realize what I did wrong. Duh. For anyone who may have the same slipup in the future, my baseDN was being too specific and missing my groups. The baseDN that worked was ou=MyBusiness,DC=myDomain,DC=local