powered by Jive Software

Some Active Directory users not showing up in Group

We set up OpenFire and Spark the client a couple of days ago - We are testing right now, but, have noticed there is a hand full of people that are in a Group in AD that are not showing up in the Shared Group in Openfire. We tried removing that person from the group in AD, then re-adding them but this did not change anything. You can see them logged into Spark via the OpenFire interface in the session module though. Also, when you go into the users Roster they are not showing anyone - Plus there “shared” group is not the same as everyone else’s. Any indea’s? TIA

There is a 4 hour cache or so in Openfire. In the openfire admin console, goto “cache summary” and delete the user and roster cache, and then re-login to the server. You should then see the users.

I did try this after my first post - But, this did not work. Are you saying that after I clear the cache it will take 4 hours to rebuild??? I also, tried to clear Group and Group Meta Data cache. But, these 5 or so people are not showing up. Thanks

My expierence is that by default the cache takes roughly 4 hours to update. If you delete the group and roster cache, it should update for you then. You might want to try a restart of the openfire service if its not working.

I am using 3.6.2 agaisnt AD 2003, and If i change groups in AD, as long as I clear the cache, the changes are reflected right away.

Thanks for you help - But, it looks like I have taken a huge step backwards. I was not getting any where so decided to remove Openfire. The re-install was going fine (with Ldap) - But once I get to the last screen to add me in as a admin it gives me the following error "No username was provided or the specified username was not found. "

I am using the correct DN and all - This went fine the frist time we installed - Just had a problem with a few users nto showing up in the shared group.

I am at a lose now

make sure you have the full JID specified for the admin user. I had a problem with that previously

yeah I did - First intial, last name - I tried a bunch of different user names and the admin account with no luck. I ended up skipping past all that - I can get to the log in screen - But, ya know cant log in or anything - Oh well for right now - Frustrated - Thanks for your help. I will give it another go later.

I think we’ve got the same issue.

Users randomly fall out of group and no amount of cache clearing fixes it.

A restart fixes the problem but it reoccurs shortly afterwards…

Okay - This is completely driving me insane - haha - I went as far as formatting the whole “server” (windows XP Pro). I cannot add a user admin - I get the error No username was provided or the specified username was not found.

I dont understand cause I had this working - Except for the fact of not seeing some users in the shared group.

My base DN is equal to were all my users are located - the admin is in the default user group - (I created a new user - being that the admin password is shown in plain txt)

After not being able to add a admin - I just click on the admin account link on the right hand side - I am unable to to change any passwords - So, I just click skip this step - Then click log into admin console - But cannot log in.

So, I am using the latest version of OpenFire on windows xp pro - Ldap server has no firewall running (for testing at this point) - Using the embeded db (for now)

Anyway - Just kind of frustrating knowing that I did have this working at one point -

Well I finally got the server re-installed. I was trying to use a OU in the baseDN - This time I just used the whole domain and everything went fine - So now lets hope all my users now show up - haha -

Okay - So now I am back to the original problem - I have formatted the Windows XP Pro machine and reloaded OpenFire - But, for some reason I have about 5 users not showing up in the Share Groups list.

What are the requirements of the AD group properties?

Can the group be a universal - security group or does the group have to be a Global Distribution Group?

I have checked the clients AD properties over and over and there is nothing different from the people not showing up in the Shared Group to the people that do show up.

Any ideas?

TIA