Spark 2.0.1 - User''s no longer able to login

Hi since making Spark 2.0.1 available we have a number of users who can no longer connect to the Wildfire server.

The only common reason appears to be that they are connecting from a different subnet at an office located in another country. The Wildfire server is running 3.0.1 - it was running on this version when we were connecting using Spark 1.1.4 with no issues - so I think it can only be the Spark Client causing the problem. We use an IP address for our Server name.

Previously users were running Spark 1.1.4 and had no problems connecting. Now when they try to login they get an error saying “Invalid username or password” but I know this is wrong as I have reset the password for them and even been able to login as them from my own Spark (2.0.1) client.

Does anyone know why this might be happening? I think we will have to stick with Spark 1.1.4 as this is major problem for us.

Check the “Advanced” options. As for our domain we are using another port than 5222.

Spark 2.0.1 deleted those settings so the users had to reenter the Server and port in the advanced tab.

Thanks but sadly that hasn’'t fixed the issue.

I’'ve removed Spark 2.0.1 from the Wildfire server so its no longer available as an update.

We had the exact same issue: using Wildfire 3.01 and upgrading from 1.1.4 to 2.0.0 and then 2.0.1 (Windows 2000 and Windows XP). In fact, we had situations where Spark would not launch at all (being stuck open but not usable). We had to quit it from the Windows Task Manager (for those clients with auto-login).

I found a SSL Enabled setting in the Wildfire server properties. I disabled that box and we could then login.

I’‘m not sure if that’'s really the underlying problem but it seems to have solved the login problem for us.

Thanks I’'ll give that a try

Thanks for the hints everyone … I opened client ports (5222 & 5223) on XP firewall and my problem went away. SSL still enabled on Wildfire Server

I am having a similar issue here. Some users seem to work fine, but others not so much. Being one of those users who do, I find that I’‘m able to connect using the unencrypted port, with Use OLD SSL Port Method unchecked, but the other combinations (OLD SSL checked with unencrypted port, OLD SSL unchecked with encrypted port, and OLD SSL checked with encrypted port) don’‘t work. My XP firewall’‘s off and there’'s nothing between me and the server. I checked my Wildfire logs and see that when I try the OLD SSL checked with the encrypted port, I get ‘‘Invalid username or password’’ from Spark and the following from the Wildfire logs:

2006.09.18 18:12:27 [] Connection closed before session established
65d588[SSL_NULL_WITH_NULL_NULL: Socket[http://addr=/,port=3645,localport=5223]]

and the addr is the IP that I’'m using.

Just thought I’'d throw this info out there, fwiw, which may not be much.

had the same problem too.

A reinstall worked for us. Also had to download the spark twice off the server for some users - i.e. via sparkmanager as it installed and still thought it was 1.1.9.


Hey all – still having the same issue here as well (after clients upgrade Spark clients)

even opened port 5222 (we only had 5223 previously) and it still fails.

any ideas?



rlinger wrote:

any ideas?

Hi Charley,

We use Wildfire/Spark internally on my company. Users with spaces and some “swedish characters” in their usernames cannot login using spark. Might this be an issue for you too? I’'ve written a new thread for this here:


I am having same problem. SSL on will not work with Spark. If I turn SSL then it will work. However, I have gaim running with SSL and it works fine.

I upgraded to 2.0.2 over the weekend and it appears to have corrected the issue for me. I’'d be interested if it did the same for others.

2.0.2 should have the connection fix, so I’‘m glad it’'s working