powered by Jive Software

Spark 2.0.4 bug? - Always starts at startup

I just upgraded to Spark 2.0.4. I noticed that it always starts up with windows even though I have the (Preferences -> Login ->) Launch on Startup option unchecked.

I have looked elsewhere for a setting which will disable Spark from starting up with windows, but have been unsuccessful.

Yeap. It seems this option in Preferences is broken in 2.0.4 (maybe earlier, because i’'m always deleting it from startup registry manually after upgrade). But it puts registry entry in startup when you install Spark, so it works there. Only Derek still dont want to add “Start on system startup” checkbox to Spark setup so i dont have to delete registry entry every time i upgrade. Or maybe he just couldnt do that?

Well, hopefully this has been entered as an official bug and will be fixed soon.

gbobeck wrote:

As an end user, I find this to be extremely annoying.

You can say that again!

I haven’‘t tried the latest Spark version, but from the changelog, I don’‘t suppose it’'s fixed in 2.0.5.

wroot wrote:

Only Derek still dont want to add “Start on system startup” checkbox to Spark setup so i dont have to delete registry entry every time i upgrade

Where exactly in the registry did you do that?

Adding:

I think I’'ve found it: …\Software\Microsoft\Windows\CurrentVersion\Run

Message was edited by: aznidin

aznidin wrote:

Adding:

I think I’'ve found it: …\Software\Microsoft\Windows\CurrentVersion\Run

Maybe. I dont remember exact path. Just doing this with RegCleaner

@“hopefully this has been entered as an official bug and will be fixed soon

Hi,

if someone could tell me which SPARK-issue this should be I could avoid to create a new one.

One should be able to disable the autostart feature during the installation, and probably also:

auto start

auto login

store password

start minimized

start now <-- is already implemented

LG

Derek did create SPARK-428 and did schedule it for 2.0.6, so one can vote for it.

I’'m still seeing this problem in 2.0.6.

Of course, it could just be my system is at fault.

gbobeck wrote:

I’'m still seeing this problem in 2.0.6.

Of course, it could just be my system is at fault.

Yeah, still not working for me too.

Well, that was suppose to be fixed. I’'ll do some more testing and get this fixed in the 2.0.7 release. Sorry about that guys

-Derek

ddman wrote:

Well, that was suppose to be fixed. I’'ll do some more testing and get this fixed in the 2.0.7 release. Sorry about that guys

-Derek

Eh, stuff happens. Thanks in advance for fixing this

It looks like this problem is still there in the 2.0.7 release for windows (non msi version).

so it’'s time to reopen it again. JIRA issue i mean

Hi,

Was wondering if the issue about Spark starting up automatically in a Windows environment had been fixed…I poked through the 2.0.8 ChangeLog and didn’'t see any reference to it.

Also, if/when it is fixed, is it just the client that will need to be un- re-installed?

Thanks.

Michael

MBowen wrote:

Was wondering if the issue about Spark starting up automatically in a Windows environment had been fixed…I poked through the 2.0.8 ChangeLog and didn’'t see any reference to it.

What is the issue for you? There was a problem that “Launch at startup” Preference wasnt adding or removing Spark entry in Windows startup registry. In 2.5b3 it works. Or are you talking about that Spark setup is adding Spark to startup whithout asking a user? If so, well, i cant help. Derek (developer) said once in chat that this will stay like that. Was really bugging me, but now i use msi install to upgade, and it doesnt add Spark to startup.

MBowen wrote:

Was wondering if the issue about Spark starting up automatically in a Windows environment had been fixed…I poked through the 2.0.8 ChangeLog and didn’'t see any reference to it.

Also, if/when it is fixed, is it just the client that will need to be un- re-installed?

It looks like it was fixed for 2.0.8.

In any case, this issue was caused by Spark not disabling the registry setting to start Spark up at system start up. Making matters worse, the uninstaller does not remove that registry key upon uninstall (2.0.7 was guilty of that!).

Here are the steps I used to fix this issue: I just uninstalled 2.0.7 -> Unsuccessfully tried to install 2.5.0-b3 twice -> gave up trying to install 2.5.0-b3 -> Installed 2.0.8 -> Used a registry editing tool to blow away the registry key which caused Spark to start at system startup.

Ok, my bad…sort of…

I looked here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

and also in the Startup folder and saw no reference to Spark.

Those were the only places I knew to look for programs being launched automatically when Win starts.

I didn’‘t realize that the MSConfig Utility showed additional items, I thought it was just an additional way to access those two sources and to do some other config’'ing…

Found Spark on the list in MSConfig, unchecked it, and all is good.

Now, that that is solved, don’‘t take my wanting to stop it as a bad sign. I’'m still in test mode. But I will say that the Wildfire installed (Win2K3 server) more easily than you could imagine. I had Wildfire installed, and the first two clients rolled out in a couple of hours. VERY NICE WORK! Congrats!

m

gbobeck wrote:
MBowen wrote:

Was wondering if the issue about Spark starting up automatically in a Windows environment had been fixed…I poked through the 2.0.8 ChangeLog and didn’'t see any reference to it.

Also, if/when it is fixed, is it just the client that will need to be un- re-installed?

It looks like it was fixed for 2.0.8.

In any case, this issue was caused by Spark not disabling the registry setting to start Spark up at system start up. Making matters worse, the uninstaller does not remove that registry key upon uninstall (2.0.7 was guilty of that!).

Here are the steps I used to fix this issue: I just uninstalled 2.0.7 -> Unsuccessfully tried to install 2.5.0-b3 twice -> gave up trying to install 2.5.0-b3 -> Installed 2.0.8 -> Used a registry editing tool to blow away the registry key which caused Spark to start at system startup.

The registry key is HKCU\Software\Microsoft\Windows\CurrentVersion\Run

So installing 2.0.8 over the top does not fix this? I have to run a script to delete this reg key?

ES13Raven wrote:

The registry key is HKCU\Software\Microsoft\Windows\CurrentVersion\Run

So installing 2.0.8 over the top does not fix this? I have to run a script to delete this reg key?

For me, uninstalling 2.0.7 and then installing 2.0.8 didn’'t fix the issue. But then again, this was on my Win 98SE box (never had a chance to test it on my Win2k box since it very rarely gets rebooted), so your mileage may vary.

I think some of the older versions of Spark may not have completely uninstalled everything on my computer.

In any case, I run an anti-spyware program every week and used its registry editing tools to disable the reg key. One could run regedit too.

I would suggest experimenting on your system. Most likely, it may not be an issue.