powered by Jive Software

Spark 2.5.3 Bug: using xmpp:/JID doesn''t always work

I stumbled across the feature of being able to initiate conversations using the URL xmpp:jid, This is great, as it allows users on our Sharepoint site to have an option to message online users and for Spark to pop up a conversation window.

However, it doesn’'t seem to work if Spark is not running. In this case, it launches Spark, but does not start the conversation.

cheers,

DJ

Message was edited by: DeeJay

I’m having trouble with this one too. It used to work with older versions of Spark, but suddenly it stopped working. I’ve installed 2.5.5 and it still doesn’t work with either Internet Explorer 7 or Firefox. I’ve tried formatting the url both as xmpp:foo@bar and xmpp://foo@bar and neither work. IE will display a “The webpage cannot be displayed” error with the added detail “Some content or files on this webpage require a program that you don’t have installed.” Firefox displays a popup that says it “… doesn’t know how to open the address, because the protocol (xmpp) isn’t associated with any program.”

Any help?

I assume the protocol was nolonger automatically registered after a certain point.

Adding the following to a reg file and double clicking it (making sure paths are ok) will ensure it works in IE:

Windows Registry Editor Version 5.00

“URL Protocol”=""

@=“URL:XMPP Address”

@=“C:
Program Files
Spark
Spark.exe %1”

The problem of using it when Spark is not running still remains though; the client is launched, but no conversation window opened afterwards.

Hi,

I did try it with

@="C:\\program Files\\Spark\\Spark.exe start_chat_jid=%1"

and my xmpp:foo@bar link got to “xmpp:foo@bar” within Spark. So it seems that Spark knows how to handle the well-established parameters while it has no idea about xmpp:.

LG

Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\xmpp]
"URL Protocol"=""
@="URL:XMPP Address" [HKEY_CLASSES_ROOT\xmpp\shell] [HKEY_CLASSES_ROOT\xmpp\shell\open] [HKEY_CLASSES_ROOT\xmpp\shell\open\command]
@="C:\\Program Files\\Spark\\Spark.exe %1"

That is odd; modifying the reg file to use the parameter you specified actually starts a conversation (and launches Spark if necessary)

However, the address appears incorrect (and therefore does not reach the recipient) if Spark wasn’t running at the time of the xmpp:jid being requested.

SPARK-831 … already fixed in SVN and in 2.5.7 which is not yet available

Thanks for the update. I presume 2.5.6 is ready to go then (or at least the beta is?).

Seems the fix just missed this version…