powered by Jive Software

Spark 2.5.4 Incoming Chat Request Issue

We’'ve noticed since upgrading to 2.5.4 that when a Incoming Chat Request appears from FastPath the window will not go away whether you ACCEPT or REJECT it. the window Stays there. You have to exit Spark and go back in each time.

Another issue…

the User making the Request from the site using the FastPath button to start the chat session, their window does not change after 60 seconds stating that “No was is available, please click here to email”… It just continue to say searching for someone even when the openfire server is set to stop after 60 seconds. Sometimes it works, most the time it does not and just hangs there.

Any help or suggestions would be appreciated otherwise this is useless to us.

This is really annoying and we have not received a response. Can someone atleast tell me if you are going to fix this? We own the Enterprise edition of OpenFire and use the Spark client. Whenever someone initiates a support request using the FastPath button for Live Chat, it opens that ACCEPT or REJECT window. Well, it doesn’t matter if you accept or reject, the request window never goes away. Happens to everyone that uses spark in our company. Then they have to completely close the client and get back in. Which is annoying when you get like 10 requests in one hour.

Please get back with me on a fix or atleast if its in the loops to be fixed.

Joey

jcox@copcp.com

Joey,

I moved this thread into our Enterprise support forum so that our support team will take a look at it, since it is an Enterprise issue.

Cheers,

Alex

Hi,

I’ve never seen this before. Is this simply reproducable in the 2.5.5 release? If so, could you delete your error logs, startup spark and do the chat request and send it off to this forum. I’ll look to see what could possibly be the issue.

Thanks,

Derek

Would you try reproducing this on 2.5.5? I experienced similar behavior on 2.5.4, but not with 2.5.5.

I’ve noticed similar but slightly different behavior. I thought it was me. In 2.5.5 when you hit accept, the window disappears but the box with the support chat in it never shows up. So the person requesting support just keeps waiting.

Hmmm. Interesting. The only thing I can think of is that you are using a much older server/enterprise plugin with the current Spark client. Could you list out your configuration please

Cheers,

Derek

Oops! Sorry about that…bit frazzled today. I just downloaded and installed everything about two days ago. I’m using Openfire Enterprise 3.3.2 and Spark Fastpath 3.3.2 with Spark 2.5.5. My server setup is running on Windows SBS Premium 2003 and it’s using Sun Java 1.6.0_01 and Appserver says jetty-6.1.x if that’s important.

Noticed a possible Issue… I used the Plugins Update to upgrade the Enterprise piece of the server to 3.2.2 but the OpenFire Enterprise Console says 3.2.1. Spark is now 2.5.5 for everyone and will see if this fixes the issue.

I’m not sure why the Plugins says OpenFire Enterprise 3.2.2 is installed yet the server system settings says 3.2.1? Can someone explain that to me?

Also… Why the hell does the Console log you out in like 10 seconds anytime you access the FastPath? Does this happen to anyone else? Its a complete pain in the ass when you’re trying to customize or fix something and have to log in 20 times in only a few minutes. Crazy.

I tried this out again today with my Spark 2.5.5 client. This time when I hit accept, the chat box appeared…but on the client end it told me that it couldn’t connect me to an agent…even though it had.

Hi Techi,

Could you check if you have any room permission going on with Group Chats in the admin? One possible cause is that you have owners set for particular rooms for creation and this can conflict with room creation of fastpath rooms.

OK…I checked and I don’t. Room creation is set to allow anyone to create a room. I just tried it again.

I get the incoming request and accept it and the other me joins the room. The web screen loads the box for me to talk to myself as agent but then loads the error of “We are unable to connect you to an agent. Please try back later.” I tried disabling my firewall on the off chance it was interfering but that didn’t help.

Hi TechiMi,

Are you using web authentication turned on in Fastpath?

-Derek

Nope. Even though I was testing it on myself I knew that wasn’t an option I wanted to turn on since if it ever went live no library patron was going to have an Openfire acount.

Is it just me or are you trying to test this by connecting a Chat session to yourself on the same pc? I have a feeling there is no way to route an IP or second chat window if that is the case and you would get an error. Just checking. Otherwise, the other option is you either don’t have something configured that needs configured or ports are being blocked. Make sure to try connecting from 2 different pc’s when using this and make sure that FastPath ports are enabled on the server side and there are no firewall issues on either end.

-JC-

It’s not just you. Today I was trying to talk to myself from the same machine. Originally it was 2 different machines.

I just tried it from 2 alternate machines, all with the same result. The box will open, the user requesting assistance will enter, on their end the chat screen opens and says they’re talking with agent, then it says unable to contact agent, and then that the chat was closed by the agent. Meanwhile, the chat is still open on my end but states that the requesting party left the room.

There are no client-side firewall issues. Server-side it would be harder for me to tell as the only firewall on the network is the one in the cisco router and by the nature of the library system I belong to, I don’t control that router. The chats do connect which led me to believe the firewall wasn’t an issue but if they could connect then fail over a firewall issue, I’d have to contact the central system about the ports. Does fastpath use a different port than spark? Because Spark itself connects just fine, and I don’t see a port specific to fastpath in the list.

The Cisco router you are referring to is only for access to the internet and would have nothing to do with your current setup. This is assuming you have the OpenFire server installed on a box inside of the Cisco and you’re also accessing it from PCs inside as well. The ports i was referring to are configured on the Openfire server side. Since you are able to connect, are you sure there is no other software running, Anti-Spyware, anything? Disable all the Antivirus completely and then test it again. It sounds like its making a connection but a program on either the pc or the server is disconnecting it Here is what our server settings look like port wise for our configuration which I think if they are all set, would any scenario to work pretty much. You might try this from the Server as well. I’ve never tested that but in there if its an issue with software on the pc’s, maybe it’ll work from the server and at atleast eliminate that its a server side issue? not sure. You might want to post a new Topic as to get attention from the support guys as this is kind of a continuation of my previous support request which they just fixed and likely are disregarding now with the latest IM Gateway update.

-JC-

I am having the same issue. I noticed something interesting, though.

I have one workgroup set up, named “Test”. If I connect from any PC to that group via http://server/webchat and type in a normal string in the “Name” field, it errors out in the way described by TechiMi.

However, if I connect to the group and specify a name that is identical to the workgroup name, everything appears to work as it should. This works for any workgroup name I’ve tried, without spaces/punctuation.

Has anyone managed to resolve this issue?

Hi charlesw,

TechiMi was having a couple issues, could you please tell me the issue that you are having? This original post was to troubleshoot the accecpt/reject window not going away.

If this is a different issue than the original issue, could you please start a new discussion with all of the information reguarding your problem, and you can reference this thread there.

Cheers,

Will