powered by Jive Software

Spark 2.5.8 Phone Client Crash on OS X 1.5

Hi All,

I wasn’t able to find any references to this, so here’s a new topic. I have an Asterisk 1.2 server on the Internet and I have successfully installed and configured the Spark phone client on my mac and my pc. On Windows XP the phone client seems to work. On OS X 10.5 it crashes as soon as the call is answered or terminated, taking the spark client with it.

Anyone else out there using this combination of things? If so, could you tell me what I need to do to make this work?

Thanks

Darren

I should add that I also have an openfire server on the Internet at polgara.mepad.net. The asterisk server is on vongate.mepad.net.

Thanks. Sorry for the omission.

Darren

The windows XP client works fine. I had a 3 hour and 20 minute voip call to a Russian residential DSL last night and the system performed flawlessly. This is great feature. I wish it worked on my Mac.

What information do I need to provide to have you folks look into it?

Thanks!

Darren

Same thing happens here on my two macs. Would be nice to see fixed.

Where is Sparkerror log located, if that would be of any help to the developers? Tried to look to inside the .app but the errorlog there was empty.

Same thing here, so I add myself to the other two to require a fix. Thanks in advance

I can confirm that Spark (even the latest 2.6 beta) crashes EVERYTIME a call in answered with the SIP plugin.

Tested on 2 machines, OS X (10.5).

Has this been addressed in any shape or form?

I compiled the SIP plugin from source and it looks like there was a fix dumped into source a while ago. I have attached the working plugin for anyone to use in the meantime.

Dump it into your plugins directory and overwrite the original.
sparkphone.jar.zip (1912254 Bytes)

We’re also seeing this. Spark 2.5.8 on Mac OS X crashes whenever a computer-to-computer call is received or made. This is even without the SIP plugin, just a normal Spark voice chat.

It is still crashing.

Mac OS-X 10.5.5

Spark 2.5.8

Hi everyone,same problem on OSX 10.5.6 on IMac Intel Core2 Duo.

I tried to change the order of the JVM, I also installed the 2.6.0 beta2 but nothing changed.

Any solution yet?

Thanks,

Ricky