Spark 2.5.8 trayicon not work in gentoo linux


I’m using gentoo linux, with KDE 3.5, and JDK 1.6

I download the latest spark (2.5.8) for linux which I see in the change log the trayicon was already solve in previous version. but when I start it, I find no spark icon appear in my tray, if I “close” spark, it will just disappear, but running in the background where I can not get it back.

I did a look into the Spark startup script, where I find in the last line trying to load library files from lib/windows, and I change it to lib/linux, but still not having it in my tray.

also no result of version 2.5.8 of this problem I could found in this community. it seems there is something very simple but I did not figure it out. any tips?

thanks in advance!

any suggestion? or I need to post this issue into development section?

thanks in advance.

I found this problem happens on Gentoo, but not in Suse as I tested.

also I did test in gnome in gentoo, same problem.

so I wonder the problems is load java application tray icon in X.


the problem has been figure out with help by one my friend:

the configuration file plugin.xml shipped with jniwrapper.jar where in Spark/plugins directory was malformed at the line:

and work for me, but also I wonder in opensuse how the jniwrapper.jar shipped with Spark works, as I see there is also the same error in the error.log (I active the debug mode by add -Ddebugger=true -Ddebug.mode=true to the Spark script):

INFO: Unable to load plugin JNIWrapper due to invalid operating system. Required OS = Windows, Linux

see, there is a blank in the middle, after I modify the plugin.xml it will be:

INFO: JNIWrapper has been loaded.

wondering if suse is not using spark jniwrapper…

thanks for reading, I go for fire a bug.
jniwrapper.jar (750018 Bytes)

Thanks for this post, I also am suffering with the same problem on Ubuntu Gutsy, so I tried your fix but unfortunately it didn’t work for me. After enabled the debug mode, my error log shows:

16-Apr-2008 15:24:15 org.jivesoftware.spark.util.log.Log debug

INFO: TRAY_IMAGE not found.

16-Apr-2008 15:24:15 org.jivesoftware.spark.util.log.Log error



at java.awt.TrayIcon.<init>(Unknown Source)

at java.awt.TrayIcon.<init>(Unknown Source)

at com.jivesoftware.plugin.jniwrapper.LinuxSystemTray.<init>(LinuxSystemTray .java:102)

at com.jivesoftware.plugin.jniwrapper.JNIWrapperPlugin.initialize(JNIWrapperPlugin .java:33)

at org.jivesoftware.spark.PluginManager$

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)

I suspect this has something to do with it, does anyone have an idea what this means? I tried a fresh download of Spark just in case something had accidentally been deleted, but it still is exactly the same.



same issue on debian sid (current) amd64

hi ben,

what’s your jdk version? suppose is >= 1.6


I am running:

ii sun-java6-jdk 6-03-0ubuntu2 Sun Java™ Development Kit (JDK) 6

Does this look correct?


Not to worry, I upgraded to Ubuntu Hardy Heron, and now I have a tray icon.




I’m not familiar with ubuntu or debain, but consider is problem with the jdk, as in the exception the jive plugin jniwrapper is calling the jdk awt trayicon method…

as I read here ( this trayicon awt is support in jdk6, the execption seems your system does not have the trayicon method or problem in handle the parameters.

should be something spark developers know more…


Dear All,

Please Help me, My Spark 2.5.8 not show in tray my Linux Ubuntu 7.04, Ultimate 1.4 and Ubuntu 8.04, Ultimate 1.8