powered by Jive Software

Spark 2.6.3 - Could not use bundled JRE

Hello Everyone,

I was trying to install spark2.6.3 and I receive the error “Could no use bundled JRE.Please send this log file to your software vendor:”.

I have attached the error file for reference. I have tried every other combination( Install JRE 6 and then Spark 2.6.3, online version) to install Spark 2.6.3, but was not able to install successfully. Can someome help on this issue?

Thanks,

Pavan
i4j_nlog_2.zip (7638 Bytes)

I suggest to use offline installation instead. It has bundled JRE.

I have even tried that, i get the same error.

Can’t say what is happening exactly, but it looks like installer can’t register a path for a temporary jre extracted into temp folder or something like that. What OS and bit version? Can you run an instaler with Run as administrator?

I have win7 32-bit, tried with admin privileges. Still I get same error.

I suspect some other software or old installations (of Java or something else) is interfering or misleading the installer. But it would be hard to find out what exactly is causing that.

Have you got another client to install spark?

My idea: Install spark on another client and copy the complete folder from C:\Program Files (x86)\spark\ to your machine in a folder (for example: C:\chat). Normally it should work if you start the client now from that path without installation.

Best,

Benni

Hi Benni,

Thanks for the suggestion, I tried this too, but still does not work. I recieve the below error


Error


The JVM found at .\jre is damaged.

Please reinstall or define EXE4J_JAVA_HOME

to point to an installed JDK or JRE.


OK



Error


The JVM could not be started. The main method may have thrown an exception.


OK


I tried creating the above said user variable and set the jre path, also modified the path present in the file pref_jre.cfg under .install4j folder. But still it does not work and gives the same error.

Thanks for your help.

Regards,

Pavan