powered by Jive Software

Spark 2.6.3 not saving chat history


#1

My spark client runninw on windows 7 Pro, is not saving all my chat history. When I open a contact it will show the most recent conversation, when I click on the view conversation button it will open and show history from say a year ago, but will not have the most recent information shown. For some reason it seems to be stuck and won’t add anything new to the history file. This appears to be happening with all my contacts, so not a particular one.


#2

Actually it is saving all the history, but there is a bug in history displaying. SPARK-1407 there is a workaround in that ticket.


#3

Hi wroot,

I looked at issue Spark-1407 as you noted, and things didn’t quite match up for me. here is what I’m seeing, any help would be appreciated.

OS: Win 7 Pro

Spark 2.6.3

Per the help ticket you referenced I should enter or check for an entry of maximumHistory=xxx in the spark.properties file. First problem I ran into is that I have two spark.properties files, actually two of everything.

Location 1: c:\users\userA\Spark

Location 2: c:\users\userA\AppData\Roaming\Spark

Both of those locations contain all the files, both even contain the transcript files used for holding the chat history. However location 2 seems to be more current. Location 1 did not have the entry in the file, I tried adding, restarting spark nothing, that is when I found location 2 which had the setting, I tried removing, no change.

Problem two, in ticket 1407 it stated that from within Spark under Preferences we should see the history option and be able to adjust it, I am unable to find this setting within the application.

Problem three, if I go and open one of the transaction files directly c:\users\userA\AppData\roaming\Spark\user\User!\transcripts they do not show all the history of my conversations. There are two files one for each contact I have communicated with. Once has _current at the end. this file seems up to date with the most recent conversation. But the other file which should have the entire history does not, they are missing new data, almost as though they are not being added to.

any help you can provide is appreciated, as I have now lost information from conversations that I needed to retrieve.

thanks,

Bryan


#4

Location 1 is from older Spark versions and it was automatically imported into Location 2, once you installed some of the newer versions. It is safe to delete Location 1 folder.

This ticket is only suggesting to add the option in the Preferences. Actually, there is a patch in the works which will probably eliminate the limit and the option. It will use paginated history for faster loading. Though i can’t say when it will be done. Haven’t heard any news on that for a long time.

As you are not seeing your recent conversations in the xml files, then probably you are having some other issue. Are you sure history isn’t disabled in the Preferences? If not, then i have no clue so far what might have happened. You may try not to remove that setting but t oset it to say 100000. Maybe you are missing something in those xmls and history is actually there.


#5

I’m still testing the patch for the message history. Sometimes I get reports about messages, that are not displayed correctly (like missing some messages after a specific point). But i’m still waiting for some transcripts for testing… currently I suspect a time-formating or xml structure issue for that strange behaviour.

I’m a bit careful before committing to the trunk.

Are you interested in the current state of the patch? Maybe you could help me testing it.


#6

What exactly do you want me to test? Another version of patch? I don’t do much history checking, so can’t say much about your patch. Actually i don’t do much IM lately (probably haven’t laucnhed Spark for a month at home, also i had to upgrade my PC and i still haven’t setup everything and i’m a bit ill now…


#7

Hi, I’ve been having exactly the same problem as Bryan for a number of months. I’ve been using Spark for over two years and for at least one person that I have regularly chatted with over that period my conversation history starts at the beginning (Aug 2010) and goes on until May 2011 (a total of 400-500 messages) despite the fact that I’ve been chatting with them at least once or twice a week since then. My current conversation history with this person (in the main chat window) goes back to October 16th 2012 but gradually messages will start to disappear from the start of this, so I only ever have about two weeks worth of “current” messages and nothing new in the history file for over a year.

In my C:\Users\USER\AppData\Roaming\Spark\user\USER@…\transcripts folder I can open the history XML file and the messages are missing from there also.

In Preferences/Chat I have “disable chat history” and “disable showing previous conversation history in chat” both unchecked (and always have as far as I know).

I’m running Spark 2.6.3 in Windows 7 (although I’m sure I also had the same problem when I was running XP on an old machine).

Thanks

Mark


#8

I’ve found the problem on my machine now - the messages were actually in the XML file but the XML file was corrupted so Spark (and the XML viewer in my browser) only showed the first block of messages up to the first missing XML tag. After opening the chat history file in a plain text editor and manually fixing it by adding a couple of missing tags it appears to work ok now. After looking at all my XML chat files it turned out that pretty much all of them needed fixing - maybe a problem caused by a previous upgrade ?

I hope this might be of use to someone else with a similar problem.


#9

Don’t use simbols like this ]>. Those simbols kills Spark history XML file, maybe someone have solution how filter XML chars in Spark?


#10

Try 2.7.0 659 build. It should have such issues fixed http://www.igniterealtime.org/downloads/nightly_spark.jsp


#11

I’ve jus’t came across this issue, and updating the client didn’t solve it.
What really worked for me was manually searching for ]> in the log files and exclude them.